VaraFM with Baofeng

I posted a quick video VaraFM + Baofeng tutorial. This also applies to all other HTs.

I have no plans for the channel, might upload more videos. Subscribe if you want to see more of garbage production quality videos… or don’t.


Helpful video imho. More would be welcome.

I have an “everything in one place” set of instructions for beginners trying to set up Baofeng → Digirig → Win10 laptop running Soundmodem + Winlink Express or Pinpoint APRS. Its on an Excel sheet with lots of screenshots and some hyperlinks. I could print it to pdf. What would be a good way to get this onto this forum?

Thanks, AW-

Thank you for encouragement!
Please share your tutorial, PDF sounds great.

Hi. Would be interested in seeing your instructions. Sheet or pdf. Thanks. Mike2

Posted in the forum thread: Digirig with Winlink and UZ7HO soundmodem.

Hope it helps! KE1TLG

Great video! I subscribed so looking forward to more.

1 Like

Thanks for the video Denis!

Attempting to set up VaraFM 4.2.7 w/Baofeng (UV-5R8W) w/Digirig 1.9. Watched this vid and followed it exactly. This includes verifying ports & sound devices in dev mgr (Win10), configuring Vara PTT via com (verified correct port) w/PTT pin=RTS, resetting all Baofeng configs with subsequent reset to SQL=0 and TXP(power)=LOW (have also tried HIGH), Digirig playback & recording levels both at 20, playback enhancements disabled and recording AGC unchecked (these last three items in Win10 sound props), adjusting Baofeng volume to yield Vara ‘Audio Input’ meter @ approx 3/4, and connected via a “homebrew” cable built to the Digirig drwg, proper pin continuity verified. Attempts to auto-tune to a local Winlink node (4 mi away) yield “No Signal”.

Switch to my Elecraft KX3, same antenna, change to Elecraft homebrew cables per Digirig drwg (also verified pin continuity), make Vara PTT adjustments for CAT control, no changes to any Win10 sound props, and auto-tune yields ‘Approved’ (with a strong signal), and Winlink/Vara works as it should.

Anybody have any ideas, anything I’ve overlooked with the Baofeng setup, additional things to try, etc.?

Auto-tune as monitored by another Baofeng for both setups sounds the same … but it works w/Elecraft (which has a measly 3W output) but not with the Baofeng, which has a nominal 8W on high.

Chris K2CZ

Hmm, didn’t know KX3 works on VHF/FM… Cool.
If you are hearing your station on the monitoring HT then everything works in principle. Do you hear the remote station’s response while using Bfeng? This should give the idea if the remote station doesn’t decode your payload or your station doesn’t decode the response from the remote station.

Easy part first. My KX3 includes Elecraft’s optional 2m-4m transverter option. (Mine’s configured for 2m … I’m surprised to the point of finding it bizarre that it can even be configured for 4m!).

As K0TX is possibly alluding to, since I’m hearing Baofeng1 on Baofeng2, I’m considering it moderately-to-very improbable that this has anything to do with the Digirig. I’ve posted it here simply because it’s on point with the title, and because I then consider it probable that others viewing it will have interest and possibly (hopefully) relevant experience to share.

Lacking an O-scope here at home, I can’t say definitively, but to my ear, an auto-tune sounds different for Baofeng transmit as compared to Elecraft. Specifically, with Baofeng I don’t hear activity between the pulses associated with auto-tune changing the level 1-10, whereas with Elecraft I do sense tones between the pulses. It appears it’s now time to chase down the specifics of how auto-tune functions within Vara.

So again, it appears this issue is likely not impacted by the Digirig operation, but if anyone has any relevant experience or suggestions on this, I’m all ears.

Hello Chris , have you resolved the issue with the Baofeng ? I just purchased the Digirig and having exactly the same issue, except that I am using a Kenwood HT. Have checked all settings and can also hear the transmission on another radio . Gateway is about 3 miles from me, first try HT antenna then hooked it up to my mobile antenna, no luck. Please let me know if you have found a solution.

Thank you, Pedro
73,s KB6DKK

Pedro, I haven’t resolved my inability to hit my local nodes with the Baofeng, at least not yet. Clearly it’s not my antenna, and I consider that there’s a low probability that it’s related to the Digirig, as evidenced by my ability to reliably hit all the local nodes with my Elecraft.

Of course the fact that there’s multiple links to this chain (the cabling, the radio, the soundcard and the antenna) complicates the troubleshooting process. At this point I’ve definitively eliminated only the antenna from further consideration. As to cabling, my homebrew cable did not initially include ferrites, but I have since added (2) mix 31 snap-ons, which did not resolve the situation. As stated above I’ve confirmed proper configuration on the cable pins.

Also as stated above, I’ve made all the Baofeng and Win10 config changes found via multiple online sources (squelch=0, AGC=off, etc.) and still no joy. There’s nothing else I know of to tweak.

Via ongoing investigation I’m sensing there’s possible Baofeng timing issues (e.g. TX/RX transition) that might render it impossible to connect, given the coding of the current Vara software. More generally, I’m inching up on a conclusion that HT’s are just not well suited to this application as it now stands, and I grow increasingly suspicious that HT’s in general may not be suitably robust for emcomm.

Given my demonstrated ability to connect to local nodes with Vara FM via both the low power Elecraft and my IC-910H (using a RIGblaster), I’ve pushed aside further pursuit of this with the Baofeng for the time being. I may return to it once other priorities are resolved, but after throwing lots of time at this already, I also may not.

Chris thank you for the follow up. Very frustated and dissapointed and now worried about damage to my Kenwood th-f6. After I try 3 or 4 times to do the autocalibration on VARA, the HT will shut off and the power button is not even responsive . If I hook it up to the AC power supply it will power up.
So will not try it again. Will work with the Anytone, I have tried but cannot get to transmit.
You might be right and the HT is not comparable to work with Digirig and VARA, but I see a lot of people using HTs. I have reached to a couple of people involve with Winlink gateways , but not received any response. Will work with the Anytone today, if no luck , then will reach out to Digirig
and see if they can help. Please if you have the time keep me informed on you progress, if any.
Thank again and good luck.

73’s Pedro

FWIW, on my win11, digirig, baofeng, rollup antenna setup I set recording device level to 4 and playback device level to 80, just to start the tuning process. Sometimes, when I can’t autotune, at least I can ping, and then proceed to get a connection anyway. I have clamp on chokes on the 3ft USB cable, and keep the radio far from the computer.

I live in an area with QRM and physical obstructions. When conditions are bad, I cannot connect, but when they are good, I can connect even on low power.

Under even bad conditions, I can connect from the car with the 1/4 wave magmount antenna.

Baofengs and other HTs may not be perfect, but they certainly work for packet radio as demonstrated in the video. If your radio works for voice, then your radio works for packet/digital modes. To the transceiver it’s nothing but boops and beeps audio. Start troubleshooting with that in mind

  • listen to the traffic, test your transceiver using voice QSO, take note of the quality of audio
  • confirm you get audio from the radio to the computer (listen checkbox while troubleshooting)
  • confirm you get radio to PTT when called by the software
  • confirm you get audio on the air (requires another radio on the same frequency to monitor, take note of the quality of the sound - not raspy, crackly, overdriven)

With the above taken care of, proceed to fine tuning:

  • audio levels (start low)
  • RF link (ideally you may want to setup local peer-to-peer link to rule out antennas/distance as factor)
  • transceiver settings (there aren’t many in FM HTs, still refer to the manual, things like filter, modulation, tones etc)
  • software settings (if in doubt, see somebody who uses the repeater and copy theirs)
1 Like

K0TX, you say above “it’s nothing but boops and beeps audio”. Agreed, but as suggested here:,,,20,0,0,0::recentpostdate/sticky,,,20,0,0,95567916,previd%3D1672320020704988478,nextid%3D1670634632186718470&previd=1672320020704988478&nextid=1670634632186718470

… and here:,,,20,0,0,0::recentpostdate/sticky,,,20,2,0,92220740,previd%3D1658208150859887200,nextid%3D1656097554250294274&previd=1658208150859887200&nextid=1656097554250294274

… and here:

… and elsewhere, it’s boops and beeps with associated timing requirements that the Baofeng may be incapable of accommodating, at least in some cases and/or circumstances. Maybe it works on some specific radios but not on others, or maybe there’s some other parameter to tweak, or … ??

I’m no expert on this stuff, just a retired engineer who’s invested a good bit of time and effort in a systematic and persistent pursuit of resolution of the issue. As a result of the effort I can put a check mark next to “confirm you get audio on the air (requires another radio on the same frequency to monitor, take note of the quality of the sound - not raspy, crackly, overdriven”, and I’ve tweaked every transceiver/Windows/Vara setting I can find, thus far without success.

The timing requirement discussed in the linked materials refers to PTT mechanism. Because of the explicit software controlled PTT method, Digirig doesn’t suffer from this issue the way Signalink does with its VOX based implementation. Please let me know if I missed anything there.

With some operators reporting success (including myself and K2EUI in the link you provided) using the same/similar gear, I tend to think that the failures have to do with the settings (which can be quite touchy) and complicating factors of HTs (severe RFI, lack of purpose-specific connections).

My approach to troubleshooting is to narrow the focus and consecutively rule out as many factors as possible. In this case this might mean temporarily using minimal RF power, setting up both ends of the link locally, swapping in components that are known to be working for the purpose at hand (software and hardware).

Please persevere and post the updates.

I might be misinterpreting the discussions of timing requirements, but intuitively it feels to me like they actually are extending a bit beyond simply the mechanism of PTT, to the net effect of PTT… i.e. to the radio’s transitioning between transmit and receive. If I’m correct on that, while it might appear to be a subtle distinction, the fact that this would then bring the radio’s capabilities into the equation might be significant.

Observing either my KX3 or 910H operating through a Winlink/Vara session, there are many such RX/TX transitions, and they sometimes occur quite rapidly. W1EH’s comment in the 2nd link above “the “hang time” of the Baofeng HT’s is far too long to make any connections. I tested this at home with my packet setup and I had to change the BBS TXDELAY setting to 600ms to allow the Baofeng to transition from TX to RX. I am fairly certain that VARA requires a shorter TXDELAY than the Baofeng HT’s are capable of” elevates the probability of this being a radio issue from my vantage point. Again, I’m not expert on any of this, and it’s possible this is incorrect or that I (and/or he) might be misinterpreting, but there’s far too many similar comments online for it to seem reasonable to me to dismiss the idea.

As to KOTX being able to make connections, that’s what drove my comment “Maybe it works on some specific radios but not on others …”.

As to my persevering on this, as stated in a previous post, since I have Winlink/Vara operating properly on KX3/910H, and given the prevalent tone of the Baofeng approach being iffy, I will defer further testing to others, and won’t be chasing this very agressively if at all, but will continue monitoring in case someone comes up with a robust solution.

You mentioned that the KX3 and the Baofeng tests used the same antenna. Could you describe the antenna? Maybe I missed your description.

The antenna I use for 2m/440 operates as a tri-band J-pole (also handles 220), but for sure doesn’t look like one. Google “ed fong tbj-1” if you’re interested. Works great (SWR 1.3 - 1.5 on 2m/440), but needs to be tuned for 220, which I’ve not yet done, because it’s 35 feet up an oak tree, and I’m at an age where I’m only going to drag out my rope climbing gear when the weather’s good and I’m feeling up to it, neither of which is currently the case.

I wasn’t going to post this other info, but since the thread’s open I might as well. I stumbled across a document VARA FM Guides - Google Drive that includes the statement “Baofengs testers should make sure the menu #35 eliminates the TX tail. (STE delay elimination OFF). The Baofeng documentation is confusing. It’s not clear on some models if ON eliminates the tail or OFF does.” Also, VaraFM 4.2.8 was just released, which I’ve now updated . With the hope that one or the other of these changes would resolve the issue, I decided to give it one more shot. But before doing so, I pulled the radio up with Chirp and comprehensively went through all its settings. And still no joy!

It won’t auto-tune, nor can I successfully ping my local nodes. (My impression from listening to ping is that I’m hitting these nodes and they’re responding, but my radio doesn’t recognize it. I suspect this might be that timing thing I’ve been referring to, which I can see no way around.)

At this point this feels like a “throwing good money [effort] after bad” scenario. Unless/until someone posts a set of radio configs that for sure work, I just can’t rationalize further effort.