A solution for PTT stuck in transmit

Hey everyone,

I solved an issue recently and wanted to share the solution since it was not obvious. The problem was that whenever I plugged in the cable to the radio, it would look ok for a second and then get stuck in TX.

The setup is a debian-based machine (an orange pi zero 2w) running Direwolf, hooked up to the Digirig. I was seeing this issue with multiple radios and cables. I followed K0TX’s youtube video on troubleshooting PTT and was able to confirm that the cables were ok and the problem was either the Digirig itself or something on the computer side.

That’s when I came across this post from the Linux Mint site: Serial USB, ttyUSB, cp210x [solved] - Linux Mint Forums. It turns out that Debian-based OSs now come with brltty installed by default and this for some reason conflicts with the Digirig and its USB access. I uninstalled the brltty package and everything instantly started working.

I hope someone else finds this useful!


Congratulations on your success! Thanks for posting your solution!

73 Constrainted

1 Like

Was the radio on or off when you plugged in the cable? I’m just curious. I’ve had that happen when plugging in a radio that was on. Thanks for teaching us about brltty.

I tried both, but was seeing the same issue regardless.