Cab't get drivers for W10

Just tried to install Digirig and I get odd results

  • no new ports show up (actually no ports show up at all – new format on w10?
  • 2 new usb controllers
    • 1 new device cp2102 called other - no device drivers found
      Tried 2 different USB ports - cable is only 3 feet long
      Trying to put a pic here of the after digi device driver

      Hope that shows up

Harry KF0MAB

@ford2go That sounds frustrating. I am not running Windows 10, but I don’t want your question to go unanswered. Thanks for providing those screen captures. The OS does not display that the driver is from Silicon Labs, and says “no compatible drivers.”

When I install the driver from the Silicon Labs website on Windows 11, I get the following result in Device Manager, under Ports:


Did you get your driver from

73 Constrainted

OK it looks like you posted success with drivers here:

Congratulations! Glad I seemed to point you in the right direction.

73 Constrainted

I did get my driver, but being old and slow I haven’t installed it yet.


Harry KF0MAB