Can't get digirig to work with G90

I’ve followed the setup for a G90 I found on this site but I’m still having problems. While the radio keys up and the cat interfaces work through the WSJTX settings page I get a rig error message when hitting the tune button on WSJTX. While RFI maybe the problem I’m only transmitting 1W and I’m using the cables sold on this site which all have ferrite beads on each end so RFI seems unlikely.

Here’re my settings

Does the USB cable also have ferrites?

Yes, the USB cable has a ferrite bead on each end of the cable.

Do you experience a similar issue with the Xiegu’s stock blue USB dongle?

I haven’t tried the blue dongle let me do that… I’ll get back to you with that info in a bit

When using digirig with the G90, I had the best success when using FLRIG for all cat control, then directing the various apps to use FLRIG.

The secret (although perhaps not the only method) to setting up FLRIG with digirig is to turn the radio off, then set everything up in the FLRIG software, initialize, ignore the warning pop-up, then close FLRIG. Then, and only then, turn the radio on, then open FLRIG. If the latter versions of FLRIG don’t work, find an older version, perhaps 1.4.

With that said, I opted to simply use the CE-19 interface that came with the radio. I love Digirig and use it every day, but it just wasn’t my favorite interface for the G90.

Caution: I am not an expert. The above account is only my personal experience. There are many ways to skin a cat.

Ensure correct Baud rate for G90 is selected: 19200.

The baud rate is 19200. Check out the photos of my settings and see if their maybe something else.

No the issue when using the blue dongle is different. With the blue dongle I can’t get the radio to key up even in CAT test mode. The cable transfers files fine.

Without the key up there is no way of knowing if the original issue exists or not because it manifests itself at key up. Are you using PTT by CAT or PTT by RTS in your testing? With Digirig it’s usually RTS, though CAT option is also valid. Without Digirig it will have to by PTT by CAT.


I’ve got WSJTX running with digirig via FLrig…

However, I still like to figure out why things don’t work using just WSJTX. In WSJTX I’ve tried both CAT and RST…

The other thing that puzzles me using is using WSJTX alone it takes 30 seconds or so for the software to recognize the radio. For the little ball to the left of the frequency display to turn from orange to green. If I change band say from 20 to 40 it takes WSJTX 30-40 seconds to resync. When using FLrig WSJTX and the radio, FLrig, WSJTX sync immediately. Its weird…

I did get digirig, FLrig, FLdigi, and WSJTX and the G90 to work together flawlessly. Now I tackle Omnirig… MMSTV only supports OR…

1 Like

I found that as good as the Digi Rig cables are I still needed another MIX31 with 2 wraps right as the wire goes into the laptops USB connection. That solved it on both my computer and my wife’s computer.

1 Like

I can try that I have a few more MIX31 somewhere