Can't get PTT working with Elecraft kx2 on raspberry pi

Can someone please help me here?
I’ve got a KX2, hooked up to digirig using the digirig branded short cables. I am able to get CAT working, but not the PTT.

My settings are:

Rig: Elecraft KX2
Poll Interval: 1s

Serial port: /dev/ttyUSB0

Baud rate: 38400
Data Bits: Default
Stop Bits: Default
Handshake: Default

Force Control Lines: DTR: (blank) RTS: (blank)

PTT Method: RTS
PTT Port: /dev/ttyUSB0

Mode: Data/Pkt
Split Operation: Rig

I may have found it. I think I had MIC Button setting on KX2 to OFF because for some reason when it was set to PTT once, it was causing the KX2 to TX as soon as the Mic cable was plugged in from the digirig.

Now that I set
Mic Btn: ptt

on the kx2, it appears to PTT correctly.
leaving post up incase it helps someone.

If anyone knows what causes the mic cable (fully seated) to cause the KX2 to TX on bootup sometimes while connected to raspberry pi, I’d still appreciate insight into that. As an aside, the cables are fully seated on all ends.

PTT line is controlled by RTS signal of the serial port. It is possible that something in your system is activating it at the bootup (there were reports of gpsd doing in).


Yes, gpsd was the culprit