CAT control/VARA FM settings for FTM-400XDR?

I’m not sure if my issue is Digirig- or VARA FM-related. I’ve tested PTT to my FTM-400XDR by jumpering sleeve to nearest ring on the black connector, which does key the rig. I’m using COM10; Windoze 10 Sound settings set to 40% per instructions here. The Sound device is named Digirig, so there’s no confusion there. In VARA-FM I’ve set PTT to COM, COM10, RTS. In SoundCard settings I’m unable to key the rig. Sound level is set to -5dB. Neither Ping nor Auto Tune key the radio.

Have I done something stupid (not the first time :-/ ) or have I overlooked something?

Would Flrig be a useful tool to connect/test? If so, what settings should I focus on?

Aside: neither connector was labelled, so trial and error seems to show that the black is audio.

TIA for any and all help. I think I should be able to figure this out for myself, but no joy. Haaaaalp!


Please share the screenshot of VaraFM configuration related to PTT as well as Device Manager showing COM ports.

Good morning.

As I went to sleep last night I realized that the plugs were reversed: I said black was audio. No, it is serial, as it keys the rig as stated. I reversed the plugs (green now audio, black serial), still no joy with VaraFM.

So here are the screen shots, thanks for your assistance. I’m beating myself up that I haven’t figured this out on my own :-{

VaraFM PTT settings for Digirig

Here is the Device Manager shot

From you message it sounds like you are using a CAT-enabled cable. Here’s the info from the product page:

  • cable supports 9600-baud rate audio and hardware PTT – black connector plugs into Digirig’s audio socket
  • cable supports serial CAT control (green connector plugs into Digirig’s serial socket

COM10 checks out. With successful cable PTT test everything is lining up. Please try again after reconnecting. See if you get any error messages. You can also try a different software (e.g. WSJT-X) to rule out hardware.

Hi Denis,

Thanks for your help. WSJTX didn’t work either; the Test PTT button did nothing, nor did an error msg show. I’m confused about the cables tho. Jumpering sleeve to nearest ring on the black connector (which goes to the audio jack?), results in keying the radio. Seems like black should go to the serial jack, since RTS is set for PTT. But it doesn’t work there, either. So I’m confused about how “audio” and “serial” drive the radio.

Is there any program which would allow me to key the radio and send an audio tone, short of a full-blown application like WSJTX, etc?

Again, tnx for your help, I really appreciate it. Having been in the computer business for years, I know how frustrating tech support by remote control can be.



No worries, I’m actually enjoying the troubleshooting and problem solving.

Some theory: the socket labeled “audio” has ground, audio in, audio out and PTT:


That’s why the black connector (the one you tested by jumping sleeve to closest ring) goes into the audio connector. Since Digirig 1.6 everything required for the digital modes is on that single connector. You’ll see that most of HTs are using a single cable. More advanced transceivers also support serial CAT control which offers the alternative PTT method as well as some convenience features as frequency syncing between the computer and radio. Serial CAT is on the socket labeled “serial” (naturally) and is optional.

Now back to troubleshooting:

  • from computer’s side we determined that serial UART IC used for PTT is detected by the computer
  • from radio’s side we determined that the radio’s PTT is working and the cable is good

We are getting in some exotic territory here. Assuming troubleshooting was done right, that leaves us with the PTT issue somewhere between the PTT switching circuitry and the connector. Let’s try this: with the audio cable connected short these two points:

This does the same PTT simulation test on the cable’s jack but with the connector involved.
Let me know how it goes.

Good morning Denis,

First, let me apologize for having not read the description of the MiniDin cable I bought. It indeed does say that the black connector is audio. Also, thank you for your explanation of the audio connector pinout; now I understand why PTT is on that jack. BTW, the Digirig is a very nice piece of kit.

I jumpered the pins, which keyed the rig. The COM port settings are 9600 baud, 8, none and 1. But still no joy from VaraFM. I changed the COM port number, no difference. I’ll reinstall VaraFM and see if that makes a difference.



While we are troubleshooting PTT, there is no need to worry about serial CAT control and all the settings that come with it. In the transceiver drop down you can just select “none” for now.

I don’t expect reinstall of VaraFM changing anything and for troubleshooting I’d stick with WSJT-X because it has a simple PTT test function.

With through hole leads short causing PTT we’ve ruled out faulty connector as well. There isn’t much left there and what’s left and troubleshooting that involves the use of multimeter. Let me know if you would like to attempt.

Meanwhile stepping back to a more probable fault reason: try PTT test via WSJT-X with rig set to “NONE” and PTT set to RTS on COM10, assuming that didn’t change (confirm in device manager). If radio still doesn’t key up then please share the screenshot of config.

Hello Denis
We have an emergency so I’ve been unable to test/respond. Thnks for your patience, I’ll be back when i can
Stay well


No worries. It’s just a hobby.
Take care of yours and get back to it at your convenience.