Connecting Kenwood TS-950SDX to Digirig and computer

I have a Kenwood TS-950SDX and the Digirig but I am having a problem trying to figure out how to make it work. I wanted to use it for FT8. Are there anyone here with the same unit I have and are also using the Digirig? I need your help. Thanks and 73 de DV7SKY / N6LEI

Let’s look at the screenshot of your rig configuration in WSJT-X and the error messages you receive.

Hi Denis, attached are a couple of screenshots of the configuration I have done and the error message when I click on the “Test CAT” button.

I hope you can help me solve this problem.

Thanks and 73

Norman, DV7SKY / N6LEI


Find the COM port the Digirig is using and set that for PTT Method. It will be different from the one for the radio’s CAT control COM14. Use Device Manager to see the assignments.

73 Constrainted

You can test the serial port and cable by doing a loopback as shown here.

As far as configuration is concerned, try with Handshake set “None” and make sure the baud rate in software matches that set in the radio.

Hello Denis,

I’ll the serial port troubleshooting and loopback test.

Thanks for your help.

Hope It now works.


Hello Dennis, I did already the loop back and the cable is okay. Tested also the audio and recording and it is being detected by the computer. If all is working fine, but still is shows an error message.


I found your cables order, but not the order containing Digirig.
If you got it from Amazon then it’s in the default (logic levels) configuration. TS-950 calls for RS-232 levels. With moderate equipment and soldering skills you can attempt adjusting the configuration as shown here:

1 Like

Hi Dennis. Thanks for getting back.

Yes I got my Digirig from Amazon. And I did already the configuration as per shown on that YouTube link 3 days ago. But still it returns an error message.



I haven’t seen the screenshot of the device manager showing the COM ports. After you completed a successful loopback test I think this would be too obvious, but still let’s double check that COM14 belongs to Digirig.

Next, did you set specifically set 9600 baud somewhere in the radio? Based on this doc the default baud appears to be 115200.

HI Dennis.

Yes com 14 is assigned to Digirig. Tried to connect the USB cable then removed it. The doc that you attached is for TS-590, my unit is the TS-950SDX. I also did try changing the baud rate from 9600 to lower and even higher but still no luck.

Did you ever have a working CAT with this radio using any other serial dongle?

This issue can be due to some setting we haven’t yet spotted, issue with the radio’s serial port or maybe CTS/RTS hardware flow control related. I’d be reaching out to my oscilloscope at this time.

Here are some dedicated devices that can be used for a sanity check: