Cp210x won't install on Parallels on MacOS

My digirig works fine on my old PC laptop. I am trying to get it to work with my new Macbook air with M2 chip. I am running parallels software. When I try to install the driver I get a “FAILED TO INSTALL”. When i go to device manager there is a yellow caution on the driver but I CAN see the audio drivers. Any Ideas.

From what I can find there is not a Cp210x driver for the ARM processors on the M1 and M2 MacBooks. I have Parallels with Windows 11. But I was able to load the driver onto the Apple side of Parallels. My goal is to be able to run Winlink Express with Vara on the MacBook. I am wondering if I might be able to have the digirig use the driver that is installed on the Apple side. Otherwise I will have to use my ancient PC laptop for Winlink Express.

This isn’t a Mac only issue. I work with a lot of organizations that use tablets and a couple thought they could use “anything”. This issue also exists with Microsoft Surface devices that use an ARM cpu (SQ series.) It goes far beyond just the SiliconLabs issue, into a myriad of other serial interfaces and more. The point being, ARM is not ready for a lot of use cases beyond “casual internet browsing.”

That being said… did you try the universal Windows driver? It has two ARM variations that I have heard some users got to work, but I have not seen it myself.

I’m running Windows 11 Pro ARM64 as a UTM virtual machine on my MacBook Air M2. I installed the CP210x Universal Windows driver in this Windows 11 VM (the driver zip contains the sys file for ARM64 Windows). Windows recognizes the COM port and the sound card and the DigiRig works as expected.

Also, I’m running MacOS Ventura 13.4.1, and MacOS recognizes the DigiRig sound card and serial port as soon as it’s plugged in - no drivers needed.


I pretty much have the same setup as you. When I download and unzip the silabser.inf file is not there. I am not running windows 11 pro just regular windows with Parallels. Do I need to install that UTM software for it to work?

Thanks for the reply

I don’t use Parallels because I’ve found that UTM does everything I need. In my Windows 11 VM, after downloading and unzipping the CP210x Universal Windows Driver zip file, it creates a folder with the following files/folders. You can see that the “inf” file is there. I would assume that a Windows VM inside Parallels would work the same.

1 Like

After I unzip the zip file my directory looks the same as yours minus the silabser.inf file. I don’t have a problem installing it on my old windows 10 PC. I wonder if you having Windows pro makes a difference.

That is very strange. I just downloaded/extracted the ZIP on a Windows 10 Pro Intel PC and the inf file is there as well. There is nothing in the release notes that says anything about home vs. professional versions of Windows.

I finally got the driver to load. I was running Parallels in convergence mode. I switched out of that where you have separate windows for OSX and Windows and it loaded.

Thanks for your input.


You’re welcome. Glad to hear you got it working.

I am running Windows 11 with parallels with an M1 Mac 16G. I canot get the driver to install. I keep getting install fails with sliabser.inf install failure. I canot get past that to install the silicon labs to use the digital rig with VARA.


That’s frustrating. Are you able to install as Administrator? Are you installing for Arm64 rather than Windows?

73 Constrainted

I ran this as an adminstrator CP210xVCPInstaller_x64 and got the same error. I am not sure if its a permssion thing. I know to install it on the mac I had a persimission thing to fix.

I have never worked with your hardware, so take what I say with a grain of salt.

I don’t know how Parallels works. From the previous posts in the thread, maybe consider using another Virtual Machine host, perhaps UTM. The underlying hardware is ARM_64 (Apple M1), rather than x86_64 (AMD/Intel), right? That’s another consideration.

73 Constrainted