Digirig and mAt-30 tuner with Yaesu FT-100 - can they work all together?


To start with, my Digirig setup works just fine with the FT-100 radio alone.
Today I have connected the mAt-30 tuner to the rig, and it is also using the mini din 8 connector where the COM cable of Digirig is connected. I just created a mini din 8 split cable, so from the radio one side goes to the tuner now and the other side to Digirig.
Now the issue is that apparently my tuner is “sitting” on the din8 connection somewhere when activated in the radio menu. So I cannot connect to the radio via the COM port. When I disable the tuner in the radio menu, Digirig “sees” the radio again on the COM port.
Is there a way to let both work? I am not very experienced with electronics, hopefully there is someone here to answer this question,

Janos ON3JBS

Janos, please check out this post:

Maybe there is the same CAT through mic option with your FT-100

Thank You, very interesting read! First I will try to adjust the split cable ( which I already have ) so without the Rx line on the tuner side. When that doesn’t work out, I will try the RJ45 split option,

Janos ON3JBS

Hi Denis,

I just tried to remove Rx on the tuner side - it still doesn’t allow Digirig to communicate but the tuner keeps working.
For the time beeing I have a workaround: First I tune the radio, an leave the tuner “online”. Then I disable the tuner in the menu and connect Digirig. Now I have the PC connection, and the tuner keeps the last settings apparently. The downside is that I can only reactivate the tuner when I power cycle the radio - reactivating in menu is not sufficient.

Quick update: the FT-100 has no RJ-45 MIC connection. The MIC connector has 6 pins, and there are no pins which I could use for Digirig. It seems I cannot solve this either way…

Janos ON3JBS

1 Like

Thank you for the update. With the splitter try removing TX line on the tuner side. It’s two periphery devices trying to talk back to the radio over the same line is what causes an issue.

Thanks Denis,

I will give it a try!

Hi Denis,

Just tested the tuner with the Tx line removed - it still doesn’t allow serial connection from Digirig to my FT-100. Digirig connects only when I disable the tuner from the menu. Seems a little odd to me, but this is what happens…
If you have more suggestions I am willing to experiment further, but at the moment I don’t see a possible direction for solving this.

Thank you for giving it a try. Other than using a tuner with the pass-through serial port I’m out of ideas.

Ok, I will use my workaround then, that seems to be the only option.

There are also tuners with the pass-through serial ports.


A pass-through port would not help I am afraid, because the port is “locked” at the radio side already as soon as the tuner is activated in the menu.

I’m curious because I have a ic705, MaT tuner and DigiRig. Have you tried using a USB Hub?

Hi Brian,ˋ

There is no USB port on the FT-100, the serial port is created by Digirig. So I don’t see where could I place an USB hub.

Right, I had it confused with something else. Must be the weather!