DigiRig Com port problem

I just purchased a Digirig interface and cables for use at our club’s Filed Day station.

The PV is running Windows 10, 64 bit and the Silicon Labs CP210x driver is V 11.3.0.176. The audio portion of the interface wis working well but I’m having trouble with CAT control.

The transceiver is a Kenwood TS-570S. The serial port is set to 9600 baud, 1 stop bit.

I was initially able to get both WSJT-X V 2.6.1 and N3FJP’s Field Day log to work. (Running 1 app at a time, not trying to share the com port.)

I made a couple FT8 contacts and turned away to work on other tasks. I looked back a few min later and WSJT-X was displaying an error message complaining about CAT control and prompting to reconfigure.

I tired disabling the com port, re-enabling it, disconnecting the USB to digirig cable, rebooting the workstation and resetting the TS-570S to defaults. Nothing worked so I shut down for the night and came back to it today. The problem persisted until I disconnect and reconnected the USB cable again.

I launched N3FJP FD log and CAT control worked as it should. Shut down that app and launched WSJT-X. It too worked and I was able to change bands on the radio by changing bands in WSJT-X. However, the same thing happened after a couple minutes, and CAT control was lost again.

Thats where I am stuck now. What should be my next troubleshoot step. Field day starts Saturday the 22nd so I’m quite pressed for time

That’s frustrating, with time pressure, too.

Do you think you might have an RFI problem? Does the USB cable have ferrite beads?

73 Constrainted

Denis K0TX has published Troubleshooting Digital Modes – digirig to give you a step-by-step approach to indentify and eliminate each possible cause of trouble.

73 Constrainted

as mentioned above, RFI is a good place to start.

usb cable near the transmitter can cause a hiccup in the serial connection.

next, i had a windows install that had the power saving features all turned on by default.
it would turn off power to certain usb connected devices to save power.
serial port was one of them.
had to deny the ability to turn them off.

that had me looking at everything windows could turn off to conserve power whenever it thought it wasn’t being used.

last, polling interval in wsjt-x.
check that as well as the serial parameters.
8N1
for some reason, my windows installs vary on whether wsjt-x likes to have it all checked or left on auto. weird.

and xtra last, try 2 stop bits in wsjt-x

good luck
kb0wlf

Well, Field Day has come and gone and we muddled through as best we could.

The problem seems to be with the TS-570S itself. Every once in a while, whether or not the station was being actively used, the software in use would throw a communication error. Power cycling the transceiver always resolves the problem until the next time it occurs. I don’t know if it’s a matter of SW polling the transceiver too often or a serial buffer overflow error.

We were operating class 1A, single transmitter, and since it happened a couple times when the operator would QRT for a few min, leave the trailer and come back to the error message on the screen it seems unlikely that it is RFI-related.

More research is needed.