DigiRig + FLrig + Baofeng

I assume the reason I can’t easily find an answer to this question is that it’s either A) so obvious that no one would bother asking, or B) so obviously impossible that no reasonable person would try.

But it’s not obvious to me, so here it goes:

Is it possible to configure the DigiRig and FLrig to work with a Baofeng?
(GT-5R in this case, but it’s not important)

I know it’s possible to configure individual applications such as WSJT-X and JS8call to work as such, but I don’t want to switch to different profiles/configurations in each program depending on which radio I’m using.

I am fully aware that FLrig will not be able to adjust the VFO. I just need it to trigger the PTT.

(Also, I’m new here. I don’t know what people are like on this particular forum. But just in case it needs to be said: you can keep your bourgeois xenophobia to yourself. Any mention of “cheap” “Chinese” “crap” or any variation thereof will be summarily ignored. Such comments bring nothing to the table.)

Chris,
I keep an eye on the forum to make sure things are going smooth and civil, no need to worry about that.

Now, it is possible to configure the software you mentioned with Baofeng and other FM transceivers, the reason that it is not covered is because the digital modes that handled by those apps are typically used on SSB. Popular FM modes are Winlink via VaraFM, Dire Wolf or sound modem, APRS, SSTV.

Also, FYI you can have independent WSJT-X/JS8Call configurations for different radios and run them from separate shortcuts, even at the same time if needed. Check out the command line parameter –rig-name=xxx

1 Like

Thanks.

It makes sense that it wouldn’t be used for a lot of these apps due to being FM only. But I would rather configure FLrig once so I don’t have to have separate configurations for each FLdigi, Winlink, etc. I switch applications more often than I switch radios.

Do you have any idea what an appropriate configuration might be? I managed to get FLrig to trigger the PTT, but it wouldn’t let go.

Thanks again for your help.

For the xcvr->rig you should select “none” and RTS unchecked.
Under PTT select PTT via RTS.

Hmm. OK. I’m gonna attach a couple screenshots of the current config which does not appear to be working.


This needs to be Digirig’s serial port, otherwise looks ok.

Thanks for the help. I couldn’t get FLrig to work, but I did get FLdigi working. So that’s good.