DIGIRIG Lite not recognized

Got my Digirig lite today. It works fine on my Evolve. However it doesnt work on my Surface Go. “Device Descriptor Request Failed.”
I tried installing the Silicon Labs driver but that didnt fix it.

Any Ideas?

I’m not acquainted with the Lite yet, but I see that the Surface Go only has a USB-C port. Did you rule out a problem with the USB-C cable or adapter, such as it being incapable of handling data?

I dont think so because original DIGIRIG works fine on the Surface Go.

Digirig Mobile is USB-C while Digirig Lite prototype is USB-A.
Is there anything connected between Surface Go and Digirig Lite?

1 Like

Yes a USB-c to a multi port USB A hub. I’ve tried two different Hubs. My next step is buying a single port usb c to a. Because it works on the Evovle’s direct USB-A port.

Issue fixed

It was indeed both of my USB-C to A hubs.

Worked like a charm with a USB-C to A adaptor.

3 Likes

Device descriptors are a nasty piece of windows and can cause a multitude of issues.
I have had exactly the same issue and had exactly the same fix on a laptop.
well done in discovering the fix.

1 Like

It doesn’t show up as connected in the Device Manager (Windows 10/11), even if plugged in directly, without any cables/adapters. The fullsize DIGIRIG works just fine. Reinstalled drivers as well.

Martin,
Not seeing a COM port with Digirig Lite is normal because it doesn’t have one. Do you see the sound card components in the Device Manager and Control Panel?

Yes, I can see them there, but not to set PTT in soundmodem and VARA FM.

PTT methods available with Digirig Lite are:

  • GPIO3 of codec
  • VOX with tone on right channel

You can find relevant discussion and configuration samples here:

So I’m still trying to get the DigiRig Lite to connect to my Samsung S23 Ultra using WoAD. It works perfectly fine on my Samsung S9 tablet, but I get an error on the phone for the GPIO trigger. I have tried everything I can think of and researched the web for any help… No luck. The phone doesn’t see that the DigiRig is plugged into the USB C port. I have also tried a small USB C hub instead of just a A-C adapter, it doesn’t help. The small hub works great with a standard digirig or any other USB device.

Anyone else having this issue?

73
Dave

Are you able to use any other USB-C accessories with your S23?

Yes sir. A standard DigiRig works just fine and I use it every week for winlink check-in. I also use the port frequently for file transfer, and other functions. Very strange indeed!

The lite version available at the time of writing uses USB-A connection. The issue can be in the whatever adapting cable you use between the phone and the interface. Try connecting some other USB-A device through the same adapter.

Hi Denis, the adapter works fine. Like I said… It works just fine in my tablet. Same brand, same basic firmware, same digirig lite, same adapter. I don’t get it either.

That is strange. Both Digirig Mobile and Digirig Lite use the same audio codec. The only difference is that in Digirig Mobile it is behind the internal USB hub which shouldn’t make any difference to the host device. Please post the update if you manage to solve the mystery.