DigiRig PTT with Winlink Express

I have a FT-100 which has CAT, but Winlink Express does not support the CAT PTT function for this radio.
So I have to use the PTT function via the audio plug.
I purchased the Digirig with the combined cable for FT-8xx radios, which works fine for the FT-100. Same plugs.
So how do I get WinLink Express to trigger the PTT line in DigiRig?
And the same for the Winlink Trimode RMS software…


This configuration will work. The operator must set the frequency and mode (USB or USB-D) manually, but PTT will be pulled if the COM port corresponds to the Digirig.

Let us know how it works out.

73 Constrainted

Yes, that would work, but I am using the CAT for the frequency.
But what is more, I use it as a Winlink RMS, which requires the CAT for automatic frequency switching, and because the CAT commands are missing the one for PTT (weird) I have to trigger the DTS of the audio COM port.
I mentioned Winlink Express because it is the using the same Settings and interface as the RMS and more people would use it.

I am going to do more tests with a spare unit tonight, to see if I can select the same COM port for CAT and PTT to force the DTR high on transmit…

I think the Digirig will key the FT-100 via a dedicated com port and the 6 PIN Data connector. Frequency control is via the 8 Pin connector. If your solution with using the same comport for both tasks does not work (which I suspect), you can buy a USB-serial level converter for remote control of the transceiver. I think you are using Trimode with VARA HF. The VARA setup in Trimode lets you chose a separate Comport for PTT.
(FTDI USB CAT Programming Cable Yaesu FT-100 FT-100D CT-62 | eBay)

Right. So I got it working.
Note that all Yaseu radios (and probably all other radios too) have their PTT line on the Audio connector, not on the CAT connector.
If you have a radio which cannot do CAT PTT (Like my old FT-100) then you have to use the Audio port connector, which in this case is the audio from the DigiRig.

Luckily I now found that the Winlink Express and the Winlink RMS have the option to select both the CAT COM port, and the seperate PTT COM port to be the same port. This is clearly dealt with internally, because you cannot open the same COM port twice.

By setting the PTT COM port the same as the CAT, and selecting ‘Enable RTS’ there (and NOT on the CAT COM port setting) it actually works!

Thanks, Bart

1 Like