Digirig v1.9 gets hot does not show up in device manager

Hello, today randomly my DigiRig v1.9 suddenly stopped showing up in device manager as a sound card device. I went to unplug everything and noticed that the device was very hot. I removed all the cables and let it cool down for an hour then tried to plug it back in. Windows did not indicate anything had been plugged in nor were there any new COM ports or PnP soundcard devices available. The device begins to warm up after less than a minute and begins to get hot fairly quickly. I fear the power rail has been shorted somehow. I opened it up to see if there were any burn marks on the board but I dont see anything externally.

I purchased from the Amazon Digirig store in mid June and up until today have been using it with FT8 only since Aug 18.

Are there any options to send back for repair or exchange?

Thank you,


I’ll take care of it. Please PM/email me your Amazon order confirmation and I’ll issue an RMA.

Hey Dennis, I must be missing something. I’m not seeing how to DM on this user forum. I tried clicking your user profile but am not seeing a message button anywhere. Ideas?

Disregard, I found your email. Bit too early in the morning I suppose. :slight_smile:

1 Like