Digirig with FT-891 FT8

Has anyone successfully gotten an 891 to work with the Digirig? I purchased a Digirig at Hamcation and have been pretty much unsuccessful after several hours of attempting to get on the air, although I’m about 90% “there”. I have the Digirig installed on the computer, WSJT-X sees it, and hears with it. I used the cable configuration found elsewhere on here from K0TX “Cables for Yaesu FT-891”, which is not using the serial cable, just the USB-C in, CAT, and audio cable (from the Digirig purchase).

But here is the wrinkle. For one, I’m not sure what setting to use on the “mode” panel. None, USB, or Data/pkt. If I select USB, the Digirig/891 hear good tones. If I switch to data/pkt, the receive sound is very trashy, almost white noise, but the transmit signal is good. Nothing much gets decoded on receive. If I switch to USB, the receive signals sound good, but my outgoing signal is really nothing but maybe some hum. No FT-8 tones. At this point I don’t know if I have a configuration issue with the Digirig, or something is not set right with the 891. My choice is to receive or transmit, but not both.

If someone is out that that has this combination working, I’d really appreciate having a side discussion on settings, etc. to see if we can flush out what is wrong. 73, N7KB

Update: I ran through the various settings on the 891 and found a few of the audio, bandwidth, and similar settings were way off. After adjusting to what was recommended on a YouTube video, I just made my first FT-8 contact with the 891. Looks like things are fixed!

2 Likes

I also purchased a Digrig just before Hamcation. I got both the RS232 and Audio cables for FT8XX radios. I am trying to interface to a FT991 which is not normally done because it comes with a built in USB sound card and PTT connection; however I appear to have lost that port due to a lightning strike. I could not get the RS232 CAT to work through the Digrig so have connected a separate RS232 connection that is working. When I first hooked up the Audio cable I couldn’t get anything to work but changed several settings as suggested in the set up for Digrig and also digital settings for the FT991. I got the audio to receive and I transmitted twice. The second time I lost my audio which I know sometimes is caused by RF feedback. So I rebooted my computer (several times) and I gone back through the settings but can’t get either receive or transmit to work again. Maybe some of your changes might get me on my way.

Hi Maurice, for the radio, I set it up exactly as this guy does in his video. Some of mine were way off and causing the audio issues:

https://youtube.com/watch?v=US5HOffEp1c&feature=shares

I’ll take some screen shots of the WSJT setting’s tomorrow.

I’m no expert at all, but I guess I lucked into the right combinations today. I was about ready to order a SignalLink and start over.

Ken N7KB

Thanks for the response. I had a Signalink working on the FT991 and now it’s back on my FT1000MP but haven’t figured out the Digrig. Will watch the videos and give it a few more tries.

Some of the things for those moving from Signalink to keep in mind is that Digirig uses PTT by RTS (instead of VOX) and there is an optional serial CAT control available. PTT by CAT is also an acceptable option.

Hi Dennis, I am using the CAT connection option as you mentioned at Hamcation. I want to re-emphasis for future readers that the issues I mentioned at the beginning of this thread were all radio setting related, not the Digirig. The Digirig performed exactly as it is supposed to. I have it hooked up exactly as your diagram in another thread shows, that is without the serial cord connected. --N7KB

2 Likes

Thanks Denis, I am using a separate CAT connection and not through Digrig (couldn’t get it to work). All the CAT functions and PTT work fine. I just can’t get any audio through the Digrig. I do see the USB sound card in Device Manager and have it selected. I did receive audio once audio and was able to transmit twice. The second time that I transmitted the audio went dead. I’ve had this happen before even with the Signalink due to RF feedback but normally rebooting my computer resets everything. However, with Digrig I’ve never been able to get receive or send to work again. May be audio or FT991 settings but I’m continuing to work the issue.

K9EE

Yes, on FT-891 CAT has to be done via the direct cable between the transceiver and computer. MiniDin8 connector in the back doesn’t have serial lines like other FT-8xx radios.

As for the audio: try troubleshooting method involving plugging the headphones in Digirig’s audio socket to check if there is output from the interface.

I am using the FT991 not 891. It does have a RS232 port to connect the cable to but I was not able to get it to control the CAT. A direct cable works. I will try a headset. Thanks

We can rule out the software settings and transceiver settings because the direct cable works using the same. The issue then can be Digirig’s port configuration or cable pinout. We can go over each area individually. Please start as a separate topic since this one is specifically dedicated to FT-891.

Yes. I have two FT891 radios and both have the Digirig operating No issues whatsoever setting them up. I use the USB setting. I tried the digital setting with some issues with filters. You did good on trouble shooting. You should be good. de NA8W

2 Likes

My problem is wsjtx with digirig on ft-891 keeps loosing the input audio and throwing that error.

Do you get the error on transmit? This sounds like RFI situation. Please refer to the corresponding section of the troubleshooting guide.

Just got cables for ft-891 and with wsjtx on ft-8 receiving is working.
Getting transmit audio sound during tx. The sound is coming from the ft-891 and it’s audio level does not effect it.
Moving to digirig from cheap usb sound dongle. That configuration was ok

I just connected my FT-891 to the Digirig, using CAT control, and made a few QSOs this afternoon. OK, six QSOs…in 3+ hours.

I found some good settings in this link: https://youtu.be/afpvK8UrftU.

It was disappointing to have so few QSOs after such a long time, but I was told contacts can come and go. With so many people on 20m I was told that there could be several people calling stations, so being a low-power, portable, operator does not increase the odds of selection.

This is going to be a new learning experience.

vy 73 de David AE4LH

1 Like

Congratulations on coming to the forum without a Digirig issue! Which mode are you using?

73 Constrainted

Constrainted,

I now have an issue.

I have the the digirig and bought the cables from digirig.

A fellow ham (who is great at FT8) came and helped me on two occasions. All was fine.

A week ago I tried another FT8 session. The computer will not recognize the digirig. Same radio (FT-891), same laptop, same settings.

I run Device Manager, and see that the CAT control is on COM6 and the Digirig is on COM4.

WSJT-X has the digi set for COM3. The drop down button is “greyed out”, so I cannot select COM4.

Would you have any suggestions that I could try?

TNX de David AE4LH

I do not own an FT-891, so take what I say with a grain of salt. Here’s what I think about how to solve this in WSJT-x (and fldigi, Winlink Express, etc.)

You must decide whether you will activate PTT via CAT or via serial COM port. If you unset the “PTT via CAT” choice, you will be able to set a COM port for PTT.

Please let the forum know what you find out.

73 Constrainted

Thank you for the idea. My CAT is set to COM6 and the Digirig is on COM4. I sent a message to (what I think is) the forum.