Elecraft KX3 Digirig No Audio From Computer

My Digirig was delivered today and I’ve setup my Elecraft KX3 w/WSJT-x. I’ve selected the audio options within WSJT-X and I’m able to receive just fine on it and FT8 appears to be working fine. However, I cannot hear the radio. I’ve gone through the forum and found where they suggest opening the sound settings and selecting “listen” to this device. However, my Digirig does not show up as a PnP USB device it shows up as USB Audio Device. For context, there is no option to “listen” to such a device, I believe it’s done automatically. I’m at a bit of a dead-end. The Digirig works I just can’t hear it. From what I can tell it’s not a setting within my radio

“listen” option helps troubleshooting audio coming from the radio to the computer and you will find it in the properties for the Digirig’s recording device. To troubleshoot the playback device see if you audio level bars light up to the right of Digirig’s playback device while you tune or transmit from the software. You can also plug in regular headphones into Digirig’s audio socket to monitor the outbought audio as shown here:

If both of above tests pass then the suspicion falls on radio’s settings (maybe need to switch audio between different sources) and cable. Cable you can ring against the schematic published in the product page.

1 Like

You won’t believe me but from the time I posted that to the time you replied I had already fixed it by watching that video! Haha. Thank you

Yes, my first mistake was going to look for the “listen” checkbox under “playback” not “Recording.” Under Recording I found it and it immediately worked. But either way I’m glad I found this video as it helped me find other things I need to do like uncheck AGC! Thanks so much!

1 Like

Thanks for the update, glad to hear you are all set.

Congratulations and thanks for reporting your success!

I wasted so much time with a checked AGC! Glad to hear the video helped.

73 Constrainted