Errors on PTT line and cable test

Cannot seem to get my digirig to work.

Searching the forum I found your video on how to do some testing.

Using WSJTX (linux) with a Baofeng UV-5R I did the three tests shown in the video. Multiple times.

When connected, WSJTX–>cables and digirig–>Baofeng, I get an error message on WSJTX when pressing the test PTT button on WSJTX. Yes, the WSJTX Radio tab was set to RTS. And the Audio tab was to the C-Media Electronics device.

This is the error message that popped up on WSJTX.

“Rig Failure Hamlib error: IO error while getting PTT state”

Trying the cable to the Baofeng and tweezers to the rings, transmit works as in the video.

Leaving the USB plugged into the computer and the cables and digirig but no radio attached at the end, my ohm meter shows OL, but when I press the PTT test button on WSJTX for a transmit test, nothing changes on the meter and I get another error message from WSJTX, different from the first one.

“Rig Failure Hamlib error: IO error while opening connection to rig”

Using the video as a guideline, I am not getting the results you show in the video. Any help would be appreciated as the digirig is not working and the tests are not coming out as they apparently should.

Thank you.


That sounds frustrating. Is the 2-pin plug pushed in all the way on the Baofeng? It is a tight fit the first dozen times. Have you installed the CP210x driver for the UART/USB from Silicon Labs? The OS may recognize the device, but without the driver, it will not function.

73 Constrainted

Can you share the screenshots of the device manager showing COM ports and radio tab of the WSJT-X settings?

We want to make sure the port you refer in PTT settings belongs to Digirig (CP210x) and that the CAT is not activated:

Ok, following are some screenshots and pictures.

Had to take pictures of pull down menus because screenshot didn’t work for the pull down menus.

1 Like

Am not sure if I have the driver or not. Went to the site and to download that driver you must login. Tried to create an account and there are errors and no account is created. Always something. Tried twice. May have to send an email asking them what is going on.

Ran the no radio attached test several times but only took one screenshot and that one had the setting of USB instead of ttyUSB0! Can test again and get a correct screenshot and possible different error message.

This would explain 2 different error messages as I took the words from the screenshots. Will retest and let you know.

My error on that one!

Retested and got 45-46 ohms when test PTT button was pressed. OL otherwise. The test worked ok, so that was 2 out of 3 tests that worked.

Corrected setting test screenshot

Plugged radio in (test 1) and back to the error message “error while getting PTT state.” That still does not work.

Want to add I have 2 Baofeng UV-5R’s purchased at 2 different times. Tried the other Baofeng and got exactly the same error “error while getting PTT state.”

One thing I wanted to try was to shield the digirig. Made no difference, still got the same error

Does the radio switch to transmit before you get the error message while testing PTT?

Yes, it begins to transmit (Radio back light color and LED changes, assume it is transmitting or trying to) and within one second or so the error message appears on wsjtx and then everything locks up with the radio stuck in transmit and wsjtx needing to be linux killed because it too locks up. A couple of times it seemed as if I could click the test button off, as you did in the video, but before I can react, it locks up. There is a small space of time from the button press to lock up, think 1-2 seconds, but do not know precisely.

I agree that’s frustrating when a vendor makes you sign up for an account just to get a driver or some documentation. Here is another link I hope works better, but they do ask for cookie approval:

CP210x USB to UART Bridge VCP Drivers - Silicon Labs (

You probably already had the driver in your linux distro. I feel like you are getting closer. You might also consider moving the antenna away from the HT and computer with a leadline and a rollup J-pole or 1/4 wave magmount antenna.

73 Constrainted

I love the IBM/Lenovo Thinkpad!

73 Constrainted

Thanks. Have been to that page. Their “6 more” link goes to the linux software that requires an account. Just tried again, nope. “There was an error creating the account”. Every field looks correct to me, so something on their end is not clear or is not working.

Can try my outdoor antenna for testing purposes, but if that is a requirement for successful use it defeats the portability I seek. Will give that a try and report back.

It works, been happy with it.

OK, I went back to the page and I see the problem. Surprising for an Austin company.

73 Constrainted

I don’t get the whole SiLab’s secrecy around the driver. @Mike2, See the PM.

1 Like

Thanks for making Digirig opensource, GPL.

73 Constrainted

1 Like

Constrainted, just want you to know that you had “the answer”.

After trying many other things (usb isolator, usb port tester, 15 ft usb extension cable, “Faraday foil” and other things which I forget–and failing , failing, failing: once I connected the Baofeng to an outdoor antenna, all was well!!!

To those who may find themselves in the position I was in, please, try connecting to an external antenna on your Baofeng FIRST. Not last.

True, this affects portability in that you cannot use your Baofeng with its standard antenna which I had expected to do. Then again, if you aren’t getting your Baofeng and digirig to work together, try an external antenna.

Constrainted, thank you for your help and advice. I should have listened more closely and earlier.

The next thing I will try is to see how far away the external antenna must be. 2 feet, or 20 feet. And how large or hopefully how small, must it be to work without error.


@Mike2 I am glad to hear you are getting consistent success.

I first got on digital with the Baofeng and this one using my own ferrite chokes near the feed point:
Ed’s Antennas - Home (

I met these guys at a hamfest before they introduced their portable Vhf/Uhf antenna:
Three Mosquitos - Roll-Up Slim Jim J-Pole

I have not used this but the maker includes a ferrite choke on the lead line:
Dual band 2M / 70CM Slim Jim Antenna with 10’ or 16’ Cable. (

I used this one in the car while stationary to make my first Vara FM Winlink connections:

Tram 1185-FSMA Amateur Dual-Band Magnet Antenna with SMA-Female Connector -

Any external antenna needs some SMA ↔ PL259 or SMA ↔ BNC unions to connect the Baofeng and the antenna lead line. I also use ferrite chokes.

Let us know how your antenna distance evaluation goes!

73 Constrainted

1 Like