G90 & Linux FLRIG

Is anyone here familiar with FLRig in Linux and the settings needed to get the Digirig to work with the G90? So far I have tried messing with the settings quite a bit but I can’t get it to initialize at all. For the port I am using the line that includes usb-silicon_labs etc.

Did you have success setting up on a PC?
This way you’ll be troubleshooting only one area of otherwise known working setup when switching back to Linux.

It worked on a Windows machine.

I’m assuming there is still an issue on Linux with the same settings. I had reports of GPS daemon thinking Digirig is one of his. Below see the solution from Rocco WQ1Q:

Hi,

I purchased a digirig along with Yaesu cables about a month ago. I love the device and it works great on windows using the latest drivers. However I’ve been trying to get this to work on (serial port, audio works fine) on linux, specifically raspberry pi OS. It appears the driver is maintained in the kernel per silicon labs. It appears to be detected by the kernel via dmesg however I cannot it to work in rigctl or flrig. Do you have any tips/advice in order to get it working?

Thanks and 73

Rocco
WQ1Q

39741.315955] usb 1-1.3: new high-speed USB device number 15 using xhci_hcd
[39741.446206] usb 1-1.3: New USB device found, idVendor=0424, idProduct=2412, bcdDevice= b.b2
[39741.446216] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[39741.447346] hub 1-1.3:1.0: USB hub found
[39741.447432] hub 1-1.3:1.0: 2 ports detected
[39741.765959] usb 1-1.3.1: new full-speed USB device number 16 using xhci_hcd
[39741.912650] usb 1-1.3.1: New USB device found, idVendor=0d8c, idProduct=013c, bcdDevice= 1.00
[39741.912670] usb 1-1.3.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[39741.912687] usb 1-1.3.1: Product: USB PnP Sound Device
[39741.912702] usb 1-1.3.1: Manufacturer: C-Media Electronics Inc.
[39741.996284] input: C-Media Electronics Inc. USB PnP Sound Device as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3/1-1.3.1/1-1.3.1:1.3/0003:0D8C:013C.0005/input/input4
[39742.066434] hid-generic 0003:0D8C:013C.0005: input,hidraw1: USB HID v1.00 Device [C-Media Electronics Inc. USB PnP Sound Device] on usb-0000:01:00.0-1.3.1/input3
[39742.176016] usb 1-1.3.2: new full-speed USB device number 17 using xhci_hcd
[39742.325492] usb 1-1.3.2: New USB device found, idVendor=10c4, idProduct=ea60, bcdDevice= 1.00
[39742.325503] usb 1-1.3.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[39742.325510] usb 1-1.3.2: Product: CP2102N USB to UART Bridge Controller
[39742.325518] usb 1-1.3.2: Manufacturer: Silicon Labs
[39742.325525] usb 1-1.3.2: SerialNumber: *****
[39742.328152] cp210x 1-1.3.2:1.0: cp210x converter detected
[39742.338643] usb 1-1.3.2: cp210x converter now attached to ttyUSB0
[39743.316157] pps pps0: new PPS source usbserial0
[39743.316192] pps pps0: source “/dev/ttyUSB0” added

an hour later

Hi Dennis,

I figured the issue out. Looking closely at the dmesg logs it looked like the USB-UART Bridge was being detected as a PPS (pulse per second device i.e. GPS). Furthermore rigctl under debug was giving me device/resource busy errors. An losf command searching for ttyUSB informed me that GPS daemon took control of the device. I shut off the GPS daemon and I was able to access the ttyUSB port. A solution to this would be either turn the gps daemon off if one is not using GPS. Otherwise, if you are using GPS ensure you are explicitly specifying the GPS device you are using and disable USB hot add/remove of devices in the /etc/default/gpsd file.

cat gpsd

Devices gpsd should collect to at boot time.

They need to be read/writeable, either by user gpsd or the group dialout.

DEVICES=“/dev/serial/by-id/usb-u-blox_AG_-www.u-blox.com_u-blox_7-_GPS_GNSS_Receiver-if00”

Other options you want to pass to gpsd

#GPSD_OPTIONS=“”

GPSD_OPTIONS=“-n”

Automatically hot add/remove USB GPS devices via gpsdctl

USBAUTO=“false”

Hope this helps anyone that may ask a similar question.

73

I appreciate all the help. But no luck yet. I will keep searching.