Halfway there with G90 and Digirig

I’ve gotten a lot further than I was thanks to ‘constrained’. I installed the CP210 driver and my serial port and audio devices appeared.

Unfortunately I ran into an issue after that . I set up the devices as default communication devices and renamed them so that I could find them. However, when I open WSJTX to set up WSPR I get an error ‘can’t open audio device’. That comes up here and there and although I can apparently start WSPR, it doesn’t really seem to be doing anything. I tried receiving for a while – only a few minutes-- and got no response. Also as far as I can tell, when I tried TX, the G90 did NOT ever transmit. It does adjust the frequency so I do think that the CAT controls are working.

I had installed fldigi and I did set that up with info, but I had shut it down before I tried doing WSPR. I even tried uninstalling it in case it had setup a file that caused the issue.

(Note I did fldigi because I saw a youtube that said it was pretty much required for the G90 and digirig. )

Appreciate any thoughts.


Harry KF0MAB

Congratulations on installing the proper drivers and seeing the devices!

The troubles with WSJT-x and fldigi sound frustrating. As you know, I do not own the G90, but I can point you to the guide, Troubleshooting Digital Modes – digirig which will help you isolate and then solve each problem in turn.

My thoughts:

  1. look at Latest xiegu-g90 topics - Digirig Forum to see if others have solved your problems
  2. stay with WSJT-x until you get receive and transmit working. FT8 mode will have traffic 24/7. WSPR is too subtle for me, but it may work for you. You can use the G90 waterfall to confirm RX signals, too.
  3. make other devices, not the Digirig’s devices, defaults.
  4. post a screen capture of WSJT-x File → Settings → Radio.
  5. post a screen capture of WSJT-x File → Settings → Audio
  6. follow the troubleshooting guide.

73 Constrainted

Well I’m there – thanks to your reference. My W10 has a boatload of microphone permissions available. The one that probably was at fault was for ‘Desktop apps’ – the ones that don’t have the MS blessing. Anyway, it’s chugging away now – although I do want to tweak a couple of settings.

Thanks for saving my bacon once again.

Harry KF0MAB


@ford2go Congratulations! Thanks for reporting you are chugging away on WSJT-x modes. You will be able to quickly get fldigi, Vara HF, etc. working too.

73 Constrainted

1 Like