Headset Not working on Lenovo V15-IGL (Windows 11)

Hi everyone,

I’m having trouble with my Rampage Prestige Virtual 7.1 Surround Gaming Headset (model SN-RW77). When I plug it into my Lenovo V15-IGL running Windows 11, the RGB lights don’t turn on, and the headset isn’t recognized by my PC. Here’s what I’ve tried:

  1. Tried All USB Ports
  2. Restarted PC
  3. Driver Installation (called CM108B i guess)
  4. Compatibility Mode
  5. Device Manager Checks
  6. Power Management Settings
    Lenovo V15-IGL
    Windows 11
    B 2.0 and 3.0 ports tested


RGB lights on the headset do not turn on.
Headset not recognized in Device Manager or sound settings.
Sound continues to come out of the laptop’s speakers.

Any advice or potential solutions would be greatly appreciated. Thanks!

I tried the headset on another pc and i faced the same problem…

That sounds frustrating. I do not own your headset, but I don’t want your question to go too long without a response.

  1. Are you plugging the headset’s TRRS or TRS cable into the laptop’s audio port?
  2. Are you plugging the headset’s USB cable into the laptop’s USB port?
  3. Are you plugging the headset’s TRRS or TRS cable into a Digirig, which is connected to the computer’s USB port?

If 1, check to see which standard your headset audio is, CTIA or OMTP.

If 2, check to see that you have the USB driver that shows up in Device Manager.

If 3, check to see that you have the Silicon Labs CP210x driver. Check the Digirig documents to see if your headset’s TRRS outputs match the inputs of the Digirig Audio port.

Maybe you can reply with more information.

73 Constrainted

1 Like

Thank you for participating in Digirig forum.
Just a heads up, that the discussed topics are generally related to the amateur radio.
You’ll likely have better results posting in the communities dedicated to the gaming hardware.

BTW: this sounds like the USB cable is bad or the headset is DOA.

BTW2: CM108B is a standard audio device and should work without the need for the driver download.

BTW3: If your headphones use CM108B then 7.1surround sound is a bit of a tall claim. The codec only supports stereo output.


Hi, thank you for your response, when i googled the issue i think i saw a post like mine. So i am sorry i didnt check what this forum is dedicated to.
anyway, my headset is new ( got it yesterday) and i think its a hardware problem since that even the driver (while installing) do not detect the headset (installaion wizard asked to plug it in during installation)

Hiiii, thank you for response.
the headset is equiped with usb cable ( Undetachable/not jack) , and under the audio devices there is only 2 input speaker and headset ( normal headset that has jack connexion).
i have a concern, even if a driver is needed to be installed normally the rgb on the headset turns on even there is no driver installed, am i right? if so then the headset or its usb is broken or something, since the rgb do not light up.

again thank you for your time

I can’t answer this. With my working Yealink headset, looking at Windows Device Manager shows:

Audio Devices:
Headset earphone
Headset microphone

Sound, Video, Game controllers:
Yealink UH36

Universal Serial Bus controllers:
USB Composite Device

On the Yealink Headset, the indicator lights blink during boot after connecting the USB and then stay off unless toggle-pressed.

73 Constrainted