Homebrew cable for Yaesu FT-857D

I made the cables a while back, and appear to have audio being picked up by the PC. But I have no CAT control, no PTT. I have tried to configure WSJT-X and Winlink/Vara HF with no luck. There is very little online regarding digital settings for the radio, best I could find was for an FT-897D. Trying this rig with a Rev 1.9. I also have a 1.5 floating around, will it matter for this rig which version is used?

Yes, revision of the interface matters because the pinouts are different between 1.5 and 1.9.
Bob, please post the sketch of the cables you built for your Digirig 1.9 and I’ll check them out.

1 Like

I built them a while back (I believe right after we tested the 1.6 on my KX2) according to this:

When testing them earlier this afternoon, they matched the drawings when matching the TRS to the pins on the DIN connectors (both cables). Looking at that page again, it says “the below view is for the male connector on the cable side”. I understand that means looking at it the cable plug, and not the plug on the radio. Now, should I be looking at the DIN connector from the solder side of the connector, or from the pin side of the connector (that plugs into the radio)?

The page calls for view from the pin side of the connector.
Here’s the pinout for 1200 baud TRRS cable from FT-8xx kit:

For 9600 baud tip is connected to pin 3.

Note, that that in order to use PTT functionality of the TRRS connector on Digirig 1.6 and later you need to connect ring 2.

1 Like

Okay, tested the 1.5 and 1.9 with digirig cables on the 817.
needed to update the cp210x drivers from silicone’s web site for windoze 10. then the digirig on windoze 10 instead of unknown in device manager it now has a comm port which changes when moving from 1.5 to 1.9.
tested on both wsjtx and js8call to see the cat works and tx works outputting tones. couple hours gone to figure this out…again on windoze. used to using the raspberry pi’s and flrig. spoiled by how easy raspberry pi’s are for mobile operation. if you need my settings let me know. qrz kl7r

Yes, please share your working settings (transceiver configuration, digital modes apps etc).

1 Like

will do. the 1.9 works with 857d will test the 1.5 next.

Rev 1.5 should use TRS cables with PTT via CAT
Info for these cables can be found here.

Yaesu 857D and 817
Digirig 1.5 and 1.9 using the cables purchased from the site.
Operation system windoze 10
Run Device Manager
Scroll down to Ports (COM & LPT)
If the CP210x is noted as Unknown upgrade the drivers
Windoze will not upgrade the CP210x Drivers automatically.
Went to:

chose 4th one down CP210xwindoze Drivers
download the driver zip file and extract all.
Run the file
say yes to install it
Once the CP210x drivers are installed you’ll see
CP210x with a comm port number.

File> Settings> Radio > Rig: Yaesu 857
Cat Control Serial Port: mine was Com6, yours whatever device manager sez it is.
Data Bits 8
Stop Bits 1
Handshake None
PTT Method Cat
Split Operation None

File> Settings> Audio>
Input: Microphone (USB PnP Sound Device)
Output: Speakers (USB sound device)

CAT and TX work on mine setup this way. To use 817 on both 1.5 and 1.9 Digirig’s there are some changes to the radio choice and sound settings. i’ll note those next for JS8Call.
Hope this helps.


Baud rate used is 4800

1 Like

Thank you both for everything!!

Denis - I think I found the problem. I built my cables from the link to your page I posted above, they both use only a TRS. Granted, that page is over a year old now, and I don’t even remember if I had a Rev 1.5 or 1.6 at the time. I see now that you use a TRRS, and include pin 4 which is… PTT! :grin: So it would seem that I need to rebuild the audio cable.

I will get that done soon and update this thread.

Thanks again both of you!

1 Like

Blockquote Rev 1.5 should use TRS cables with PTT via CAT
Info for these cables can be found here .

I missed this part. So the cables I made a little over a year ago “should” work with the 1.5. I will get the 1.5 one out and try it with the cables I have made. If that don’t work, I’ll make another cable with a TRRS using pin 4, and use the 1.9.

TRS cables should work with your 1.5 with full functionality: audio + serial CAT. Please post a follow up if you run into any issues.

Still no luck tonight. Although I did figure out what I thought was a 1.5 is really a 1.3. Not sure if that affects anything or not. I have so many of these lol. A 1.3, 1.5, 1.6, and a 1.9. I found the 1.5, I’ll try it again tomorrow.

A while ago I posted a detailed how to on QRZ (With diagrams, photos, pc setup etc) This predated 1.9 for sure.

Perhaps it might help you.

73 de nc9p