How do I test if my digirig is good?

Hooked up a new digirig to a vx-6 and it worked as hoped . Made a peer to peer contact and email exchange through Winlink and vara fm (repeater)Fired up the same laptop and radio the next day and I cannot make a connection . It has tx and receive, but has a no signal report after a ping .
The same laptop when used with two different hf radios runs Winlink hf fine (minus the digirig)
That same laptop and proper cables with the digi has the same problem on a icom 2300h.
What’s the chance something happened with My digirig and I’ve spent hours playing with settings in vain? I’ve tried everything repeater and simplex with the same issue and followed the set up instructions from the web site with two different laptops with no luck .
What do I try next.

1 Like

Jeff,
Please check out the troubleshooting guide, find the category that describes the issue and try out the recommended solutions:

Please follow up if you tried that and still need help.

1 Like

Checked everything again and will purchase a new usb cable as the one that came with the unit seems a bit loose.

1 Like

Can I use the icom 2300h cord with a g90 to test the digirig unit ? I realize I won’t have cat control and will have to spin the dial but it would be an easy way for a quick test platform. The g90 is working on Winlink and Vara HF so that would eliminate some variables.

1 Like

The Xiegu’s pinout for the mic jack appears to match that of ICOM so in theory this might work.

You’ll likely get a better mileage out of MiniDin8 connection in the back as it is a purpose-specific.

When it comes to general troubleshooting, please refer to the guide at:

The idea is to isolate and independently test individual functions: audio in, audio out, PTT, CAT and address a specific issue when discovered.

1 Like

Thanks for the input, too many variables for the setup, it keys up the radio but no luck so far hitting the closest node.
I’m going to go through the system again with the troubleshooting guid and possibly buy another digirig as I’ll be able to eliminate that variable as the cables that came with are new and the pc is sending on them. If it didn’t plug and play perfectly the first time I fired it up I’d think it was in the pc but I’ll get back to it and see what I can find

2 Likes

Going back to fm that is as this is the mode I need for races

1 Like

Thank you for the help , I was able to connect and send with my VX-6 . Found two issues that may have contributed to things not working

1 Fldigi had control of the com port even though it was not open (uninstalled it)

2 Placing the radio In monitor to open the squelch made sure it received the return signal

3 Likes