ICOM 2730 FULL CI-V control and Audio out of Speaker 2

Did some analysis, putting in a forum post for digestion and assistance.

So, the 2730 does have CAT control.
If you look at the 2730 ci-v manual carefully. 3rd from last page I believe. You see a little drawing I/o on ring and audio on tip.

Their is an elegant integration possible here with the DigiRig.

The goal is CAT control and audio and ptt ofcourse.

This cable does PTT from the “audio” side which im guessing has a GPIO of some kind.

The Data side im guessing would go to CAT control. The only thing that would be “unique” to this setup would be the speaker out jack is used for CAT and AUDIO so it would an intersting cable but i think it should work. And it looks like you can utilize both at the same time.

Hypothesis was, I could make it work utilizing the basics in these pictures

I was able to get CAT control to work along with Audio stream with a custom cable i made.
This is Digirig independent at the moment. I just wanted to make sure it worked…
I am currently using the RT systems 29a cable for CAT control.

Currently i have full CAT control. Audio.

I will now test the digirig with it using the RTS 29a cable.

DigiRig is working as expected with a custom cable I made for the audio and PTT side along with a custom y-cable on the speaker out/ci-v dataport of the radio.

I have a RT systems 29A cable being used currently for CI-V control.

I see no reason why the DigiRig wouldn’t work for CI-V control with this radio.

I have a couple test cables I can use to test the Data side of the DigiRig.
I just need confirmation on the DATA side pinout. Is it TRRS or TRS?

For a CI-V connection, what pins would i use on the Data Side?

Sleeve for ground but which one for data?

Well, i have connected a TRRS to the digirig serial side utilizing TIP and sleeve.

It works, and i can GET Frequencies, but i cant SET anything for whatever reason. I thought maybe i fried something so i put the old RTS 29a cable back and tested with that, and it works as expected.

As it sits, I can get FULL hamlib available control to the ICOM 2730 if i use the RTS 29a data cable in liu of the Digirig serial side.

When i utilize the digirig serial side, i can only get frequencies, i cant set frequencies. Very strange.

If i issue command
rigctl -m 3072 -r /dev/ttyUSB0 -s 19200 -c 0x90 f
i get “145570000”

It works!

If i issue command
“rigctl -m 3072 -r /dev/ttyUSB0 -s 19200 -c 0x90 F 145570000”
i get “error = Command rejected by the rig” from rigctl.

Same command works with the rts29a cable but not DigiRig. I am perplexed.

Does anyone have insight on how to properly setup the CI-V mode for digirig?

Am i utilizing the right pins on the TRRS connector on the serial side of digirig?

I know i tossed a lot out there, just wanted to hopefully spark a little discussion because i am sooo close…i cant taste it.

Thanks

73s

Frank
KO4FQW

So i switched over to Windows to see if it was Linux issues cropping up.
Sadly no, it is exhibiting similar behavior.

I can poll the serial number off it. but i cant clone out of it.

Video of Digirig and RTS 29a cable / Test using ICOM cloning software
https://www.youtube.com/watch?v=8PlQnjYqnEI
PASS

Video of Digirig and custom test cable / Test using ICOM cloning software
https://www.youtube.com/watch?v=yFRUyF2nn10
FAIL

Here are the comparisons of the ports in windows. Their is a difference. Maybe this has something to do with it? I do not know enough to know what to try next.

Anyone, any thoughts?

Thanks

Frank
KO4FQW

Thanks for the detailed write up.

Re. RX but no TX: Can you post the picture of the back side of the PCB so we can confirm it was reconfigured to CI-V?

Its not pretty, lol. But i can say that the existing connections were cut and i have no continuity between where the original cuts were.

I do have continuity between the “solder blob” and the bottom right pad


Yes, that continuity is normal. Looks like you configured it correctly.
Everything being equal on the software side means that there is something electrically different. It would take a scope to troubleshoot that further. Do you have one or know anybody with one?

I dont have a scope. I may have a friend with a scope if u can help guide what to test?
does the scope need to handle anything above 3.3 v?

Scope work is a little beyond my knowledge set.

A buddy of mine was planning on making a scope out of a PI Pico.

What am i looking for? Any other options?

Thanks

Frank
KO4FQW

On the scope you would capture the signal during frequency set command from two interfaces and see if there is any difference in voltages and/or timing.

Everything should be within 3-5V.

Good afternoon,

I did caps dump of the ICOM 2730 in rigctrl and the following was spit out.
Does this mean anything to you? I noticed it says RS-232 and has attenuation and write delay,timeout and retry information.

I simply dont have access to a scope at the moment and was trying to pull information where i could.


Caps dump for model: 3072
Model name: IC-2730
Mfg name: Icom
Backend version: 20210107.0
Backend copyright: LGPL
Backend status: Untested
Rig type: Mobile
PTT type: Rig capable
DCD type: Rig capable
Port type: RS-232
Serial speed: 4800…19200 bauds, 8N1
Write delay: 0mS, timeout 1000mS, 3 retry
Post Write delay: 0mS
Has targetable VFO: N
Has transceive: Y
Announce: 0x0
Max RIT: -0.0kHz/+0.0kHz
Max XIT: -0.0kHz/+0.0kHz
Max IF-SHIFT: -0.0kHz/+0.0kHz
Preamp: None
Attenuator: None

Regard,

Frank
KO4FQW

I’m not finding anything that would look unusual, maybe port type being RS-232 if they imply the electric standard and not just common reference to the serial ports.

Digirig’s CI-V implementation uses 3.3V levels. If the port is actually RS-232 (+/- 12V) then it is a different story. Digirig can do it, but not as simplex (single wire shared in both directions).

I’ll research RTS 29a cable to see if I can find anything revealing.