Intermittent/fails driver install and error

I seem to be having a connection problem with my icom digirig. When connecting the device to any laptop it will sometimes load the com port from silicon labs other times it will just disconnect and the the error usb device not recognized. One my dell laptop is never will load but receive the error usb device not recognized every time I connect. I have tried loading silicon labs drivers but made no difference.

I have suspected that the usb connection on the device might be intermittent, disconnecting there and plugging it back in will sometimes load the driver.

At this point I can’t use it. Is not quite a year old, purchased from Gigaparts.

thanks for any ideas

Is this recent condition? Did it work well at some point earlier?

Yes it was working, I only use it when camping last year so I have not used it very much. I was using it with a very small Asus laptop but have also tried it with the Dell. I even went as far as wiping the drive on my Dell and reinstalling Windows from scratch updating bios and all drivers but the usb error persists. Is there anything you can suggest changing or trying.

Thanks for getting back to me so quickly.

Just to add, when I could get it working, it would work for a bit then the silicon driver would drop and it would lose connection.

Ok, I’ll retest and repair/replace if necessary. RMA info is in PM.

Sorry forgot to let you know. I sent the digirig by priority mail yesterday.

Let me know if you need anything


1 Like