Issues with RX, TX in Winlink VARA FM

Hi, folks. I’m encountering strange difficulties trying to set up my Digirig and I’m hoping you all can give me some pointers.


  • USB audio devices exposed by the Digirig randomly appear and disappear.
  • Lots of RFI, which is quieted when I touch the audio cable.
  • VARA FM doesn’t seem to recognize any audio input from the Digirig, showing -97dB input regardless of radio signal strength.
  • VARA FM can send PTT, but this is unreliable. Either the radio does not transmit, or else it gets stuck in a transmitting state, or else it transmits one connection attempt and hangs indefinitely, freezing VARA FM and Winlink in the process.

My guess is that there’s too much RFI picked up on the audio cable or over USB – maybe from my residential area, maybe from my laptop – which is drowning out the PTT commands as well as the audio. Or maybe it’s the radio side of the audio cable- even with the new version meant for recessed audio jacks, the connection seems unreliable.

Any pointers for what my issue might be, or what I should test next?

EDIT: I took my setup to an extremely rural area today with a noise floor around S1. I see a clear spike in noise when connecting the audio cable to my radio, so it’s definitely RFI from the computer. The audio cable has built-in ferrites; I’ll add another ferrite to my USB cable and see if that helps.

Additional information:


  • My Digirig is logic-level for use with my FT5DR.
  • My cable is the Digirig-supplied Yaesu cable compatible with the FT5DR. It’s the newer version designed to fit in recessed audio jacks.
  • Electrically bridging the sleeve and closest ring of the 3.5mm connector on the Digirig side of the audio cable will key up the radio.
  • For testing, my FT5DR is running low (0.3W) power.
  • My laptop is a GPD Pocket 3 running Windows 11.
  • Multiple connection methods were tested- short and long USB cables, USB-C-to-C and USB-A-to-C, all USB ports on the laptop, et cetera. The physical connection in the USB port is not loose. I have used other data modes from this laptop with no issue.


  • Recent CP210X drivers are installed, and the COM port is visible.
  • The USB speaker and microphone exposed by the Digirig have no audio enhancements and are marked as accessible by Windows applications. While the name of the device changes depending on which USB port the Digirig is plugged into, I ensure to select the correct device name in my applications.
  • I use a licensed copy of VARA FM 4.2.9, the most recent version. The correct soundcard devices are selected, and PTT is set to the appropriate COM port using RTS.
  • The goal is to use Winlink over VARA FM. Winlink has previously worked for me in other modes without issue.

I am having similar issues. I have checked sound levels and squelch on HT. The Vara FM receive is very “tight” with squelch completely off meter is in red and with only one bar - meter is maybe 20%. Have checked and usb port will not be closed down for sleep. I’m transmitting, can see the signal on my gateway and RMS Packet show that it sees the signal and RMS Relay opens CMS connection. I my case the PTT appears to work. Would be interested is seeing the setting of others.
TNX es Good luck

You must have AGC off in sound settings.

73 Constrainted

That solves a few of my problems, thank you! AGC was still set to ON in the Digirig input device settings. Turning that off results in normal input levels in VARA FM. After this fix, the radio still gets stuck in the transmitting state, but at least the input audio is correct now.

Sounds like you are getting close.
For RFI related issue see “sticky PTT” section in the troubleshooting guide.

1 Like

Dang it - forgot to check that. Thanks

When I had RFI trouble with a USB device and HF radio, this cable solved my problem:
Tripp Lite USB 2.0 Hi-Speed A/B Cable with Ferrite Chokes (M/M) 6-ft. (U023-006)

Doug, K8RFT

1 Like

I’ve heard good things about those Tripp USB cables for this situation. Thanks for your input Doug! Considering that I’ve reproduced the issue over multiple cables (short cables, long cables, ferrite beads, etc.), I’m guessing that isn’t my particular issue-- that said, I did notice a decrease in noise over USB when putting a ferrite on my cable, so it’s a good suggestion.

Yep, that’s where I started. I’m testing at the lowest power I can, which for the FT5D is about 0.3W. I have a SignalStick antenna with a fine (<1.2) SWR, which also means I can’t exactly put a choke balun in-line with my antenna. Adding a clip-on ferrite to my USB cable seemed to help somewhat, and it seems like adding more is my only option…

I have success with Baofeng HT and rollup DBJ-2 antenna or 1/4 wave magmount. The antenna ends up being 6 to 25ft from the transmitter/digirig/computer area. I did put ferrite beads on the lead line to the antenna. The Yaesu FT5D may behave differently.

73 Constrainted

That’s good to know. I have a few different lengths of coax I can run to a standalone antenna, and testing with a distant antenna might yield some insight into which cables are sensitive to RFI. Thanks for your input.

Update: even with four(!) ferrites on my USB cable and keeping the radio / laptop as far apart as the cables will allow, the FT5D still gets stuck in transmit. If other people hadn’t seen success with the same radio, I’d think it was an issue with Winlink or VARA!

The frustrating thing is that I have PTT control from VARA-- I can transmit the test tone without issue, and more importantly, I can stop the test tone. It’s only when I begin the Winlink connection process that I see this behavior. Any tips?

1 Like

Final update for you all. Thanks for your advice. I got to the point of four ferrites, maximum distance between my radio and laptop, trying every combination of settings I could think of-- nothing worked. I managed to try my setup on someone else’s laptop. I could key up and down correctly! I couldn’t get the input audio levels low enough, but I cut the attenuation trace on the Digirig board to fix that. I even sent my first VARA FM message.

That laptop is gone, and I’m stuck with my presumably RFI-noisy laptop, which means I either need a novel way of eliminating RFI from my cable or I’ve burned about $80 on a cool piece of kit that I can’t use. If you think of anything else I can try, please post it here.

73s de

1 Like

Thanks for the report and congratulations on your first Vara FM message. Have you considered USB Isolator – digirig for the noisier computer?

73 Constrainted

I checked in with the folks at Reddit and they arrived at the same suggestion. It sounds like this is the exact circumstance a USB isolator is designed for – maybe the noise is on the actual power or data lines of the USB cable – so I think it’s my next best bet. I’ll go with the one K0TX is offering on the store and will report back if I have success.

Hey, thanks again!

1 Like

My pleasure. Please let us know how it works out.

73 Constrainted

The USB isolator worked perfectly! I guess my laptop really is that noisy. I can now key my radios with no interruptions, and I can recommend Digirig’s (very reasonably-priced) isolator to anyone experiencing persistent cable interference issues. Thanks again for your help!


My pleasure! Thanks for reporting your positive result. Others will benefit from your experience.

73 Constrainted