KX2 / Digirig Serial Cable Question

Hi all,

I have been attempting to us my KX2 / Digirig for WinLink. But the radio would not key etc. So I started using the KXUSB cable that came with the radio instead of the Digirig serial cable and it started working fine… I have tested this with two Digirigs with the same results.
Has anyone else run into this issue? Could it be a driver or perhaps a cable issue?
Any suggestions would be greatly appreciated.

Many thanks,

Neil - K6KWI

Please make sure you configured the virtual TNC software (vara?) under the winlink to use PTT by RTS. It’s unlikely that the other interface you connected uses the same PTT method which suggests the PTT configuration is probably incorrect.

Will do, thanks Denis…!

Hi Denis,

I have tested / reconfigured, changed settings, tried WinLink and FT8. I have had exhaustive email exchanges with the guys on the KXn group and I have made no progress. I’m loathed to ask your for a replacement cable but I’m out of ideas.

Any further testing suggestions would be greatly appreciated.

Many thanks & 73,

Neil - K6KWI

PS… I did check to make sure VARA is configured for PTT by RTS.

Let’s ring the cables to see if there is any issue there. You can find the pinout info in the product listing: Elecraft KX cords for Digirig Mobile – digirig (last image).

It will not make sense to replace the cable unless we find an issue there.

I agree Denis,

I’m assuming you are referring to image #9 on that page for the pinouts. But that image does not load:

I’m sorry to be such a pain.



Thank you for the report. I fixed the listing, also here’s the copy of the image just in case:

Here are my results:

T to T has continuity

R1 to R has continuity

S to S has continuity

R2 doesn’t seem to be connected to anything. I tried all kinds of combinations.

Is there a way to test the serial port on the Digirig? Just thinking out loud… :man_facepalming:

Thanks again,


Yes, you can do a loopback test:

I see your multiple cable orders, but none for the Digirig itself. If you got it off Amazon, it’s in default configuration (logic levels), you need RS-232 configuration for CAT control of Elecraft KX. That was stated in the product page for KX cables. You can modify the configuration if you are comfortable with soldering:

The digirig was a gift. Ordered Jody Curd about a month ago.

She would not have known to specify the RS232. Rather than mess with this one maybe I’ll just order one properly configured.
Do you agree?

Many thanks



That’s definitely an option if you prefer not to deal with reconfiguration. You can still use your Digirig in default configuration with other radios including HTs for Winlink/SSTV/APRS etc.