KX3 WSJTX Setup Issue

I’ve just received my Digirig for the KX3. Familiar with WsJTX, and proceeded to do the setup for FT8.
Got it to receive/decode on FT8, but no transmit.
Noticed the transmit audio was grayed out and I was unable to change from back of radio to the PTT button.
Went thru the KX3 menu to make sure o was on Data A, but still no luck.
Assistance desired……


Let’s look at your configuration screens in WSJT-X (audio and rig).

Hi Denis, as requested, I did a reset of the KX3, and the only thing I did was was select Data A mode, and turn mic bias off.
Here’s my setup, transmit audio is greyed out, I can’t change it….


Follow on pictures Denis…

It also won’t flip frequency when I change bands…

  • KX3’s baud rate is 38400
  • PTT method should be set to RTS

Ok, Had tried that before, but tried it this time, and now it’s working…I can xmt, and the radio changes band. I get the green light as well. But I’m not receiving and decoding incoming data…anymore….
Maybe the bands are to weak…
Thank you


You can confirm radio’s audio is coming into the computer by checking “listen” on Digirig’s recording device. For this to work make sure the default playback and recording devices are set according to the tutorial.

Denis, here’s the current screen shot, still no receive data….

Let’s look at audio tab of WSJT-X configuration.

1 Like

Denis, this is my error I’m getting now with your setup…it was working at one time today.

This is different issue from the one related to no-receive.
Please make sure Digirig is at COM6 and serial cable is connected correctly.
Share your device manager screen with the ports group open and visible if you need help identifying Digirig’s COM port. Ports can be reassigned if you plug interface into a different USB port.

Call this closed issue, I was rechecking my setup, and found I had mistakenly disconnected the serial cable, reconnected, and I’m back on line now. Everything passes as should be.
Thanks again for putting up with my lack of knowledge. At 74, I’m entitled :grin::grin::grin:.



I hope you can solve the problem, I had a similar issue and could not solve it. I thought it might be in the computer settings but had the same problem with two different computers. If you solve the problem please post it.

From Steve’s latest post it sounds like he resolved his issue.
If you still need help with CAT control of your KX transceiver, please check that the Digirig you are connecting is configured for RS-232 levels.

EDIT: I looked up your orders and in the in most recent one you received RS-232 Digirig. Just make sure you use that one and not the one you ordered earlier. Next we can double check your cable connections and software settings. Please share the photos/screenshots.

1 Like

Hi Denis, ya this has been a trial by error adventure. I finally got everything working based on the last setup you gave me.
However, I was bugged about the “transmit audio preselecting the rear jack” so reloaded wsjtx from scratch and selected the PTT button. And went down the road of it not working again with the setup the same. End result was selecting it back to rear jack and now working FT8. Don’t understand the transmit audio part.
For the record I’ve only owned 1 Digirig, I ordered the Rs-232 with the proper cables from GigaParts. So mostly operator error on this end.

1 Like