Linux, DigiRig, G90, flRig and wsjtx

When I was trying to get my setup working the instructions were a bit hit and miss. I had to pull from many different partial and often conflicting sources so I thought I’d do a quick writeup for the next person with a matching (or partially matching) hardware setup.

I didn’t have many problems besides finding settings that work so this will largely be what I did to go from zero to ft8 on wsjtx.

First when I plug in USB cable between the computer and the digirig I get this from

$ dmesg | tail
[19523.618379] usb 1-1.2: new high-speed USB device number 10 using ehci-pci              
[19523.715348] usb 1-1.2: New USB device found, idVendor=0424, idProduct=2412, bcdDevice= b.b2               
[19523.715357] usb 1-1.2: New USB device strings: Mfr=0, Product=0, SerialNumber=0                 
[19523.715759] hub 1-1.2:1.0: USB hub found                                                                      
[19523.715819] hub 1-1.2:1.0: 2 ports detected                                                                   
[19523.998379] usb 1-1.2.1: new full-speed USB device number 11 using ehci-pci                               
[19524.103473] usb 1-1.2.1: New USB device found, idVendor=0d8c, idProduct=013c, bcdDevice= 1.00
[19524.103481] usb 1-1.2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[19524.103484] usb 1-1.2.1: Product: USB PnP Sound Device                                                
[19524.103486] usb 1-1.2.1: Manufacturer: C-Media Electronics Inc.                     
[19524.124953] input: C-Media Electronics Inc.       USB PnP Sound Device as /devices/pci0000:00/0000:00:1a.0/usb
[19524.181882] hid-generic 0003:0D8C:013C.0007: input,hidraw3: USB HID v1.00 Device [C-Media Electronics Inc.    
   USB PnP Sound Device] on usb-0000:00:1a.0-1.2.1/input3                            
[19524.255040] usb 1-1.2.2: new full-speed USB device number 12 using ehci-pci                                  
[19524.354853] usb 1-1.2.2: New USB device found, idVendor=10c4, idProduct=ea60, bcdDevice= 1.00
[19524.354861] usb 1-1.2.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[19524.354864] usb 1-1.2.2: Product: CP2102N USB to UART Bridge Controller
[19524.354865] usb 1-1.2.2: Manufacturer: Silicon Labs
[19524.354867] usb 1-1.2.2: SerialNumber: 58cf376f83caeb11bd7687561d69213e
[19524.355247] cp210x 1-1.2.2:1.0: cp210x converter detected
[19524.357068] usb 1-1.2.2: cp210x converter now attached to ttyUSB1

Note that there are actually two devices a sound card and a serial device.
The serial device is called:ttyUSB1. Remember this name.

Another view of the two devices:

$ lsusb
Bus 001 Device 012: ID 10c4:ea60 Silicon Labs CP210x UART Bridge
Bus 001 Device 011: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio Controller

The sound card immediately shows up in the pulseaudio volume control aka pavucontrol or in my case pavcontrol-qt. It has both an input and an output device:

From the Output Devices tab:

From the Input Devices tab:

From the Configuration tab:

As soon as I connect the g90 and turn it on I see the bar in the Input Devices tab start to dance with noise. I also muted system sounds in the Playback tab. This should prevent any notification or other noises from the system going to the radio.


If you run this without the radio turned on or if it’s not configured correctly, basically if flrig can’t talk to the radio, you’ll get this popup:


This is not really a bad thing but it can be a little frustrating when you see it for the 20th time because you still haven’t found the right configuration. Just hit Close and open the configuration dialog:

I struggled a little to get the configuration correct for the serial connection between the computer, the digirig and the g90 so here are my settings:

Note that the device I picked is the serial device that was mentioned in the dmesg output: /dev/ttyUSB1. The very first time you plug in this will likely be /dev/ttyUSB0 and next time I reboot or replug the digirig it will likely change but dmesg | tail will give you the correct answer.

When flRig tries to pick the device it, at least for me, picked some horrific looking long device name. I think that it may have tried to pick the audio device instead of the serial device. In any case it was the nice simple /dev/ttyUSB1 that worked for me.

Devices and Permissions

Now a word about ownership and permissions. In linux / unix all files have an owner and a group as well as the permissions (read, write and execute) for the owner and group.

$ ls -l /dev/ttyUSB1
crw-rw-rw- 1 root uucp 188, 1 Feb  7 21:45 /dev/ttyUSB1

This means that this device is owned by root (the superuser) and the uucp group. If you are a member of the uucp group you can use this device.

$ groups
qemu video uucp input utmp wheel charlieb

Different linuxes may have different owners (I’ve seen this group also called dialout) but the bottom line is that you should add yourself to the group that owns that device to minimize permissions irritations. I usually add my username to the group in /etc/groups like so


but that’s only because I can never remember the correct command to do it right (groupadd, addgroup, grpadd, no idea). Anyway you’ll need to logout and in again for this to take effect.

Now turn on the radio, start flrig (or hit the init button in the config dialog) and it should connect.
Note the green bubble at the bottom
and the level and the (seemingly pointless) extra dialog box here:

You are now done with flrig. It just needs to be running in the background for wsjtx to use.


Launch wsjtx. Go to File → Settings. Fill in your call, your grid and your region. This is just normal initial configuration stuff regardless of the radio.
Go to the Radio tab and select FLRig FLRig from the Rig dropdown

Select CAT as the PTT method. Not sure about the other settings in this screenshot ymmv.
Hit the Test Cat button and be pleased to see it turn green.

Now go to audio. This is a bit more fun. Remember that the digirig showed up as two devices a serial device and an audio device. FLRig is talking to the serial device but wsjtx needs to talk to the audio device.

Here’s my setup:

Here’s part of what I see when I drop down the Input box on the Audio tab.

I have seen people use selecting pulse for both and that may work but I picked the devices named here because (a) I saw flrig try to use them and (b) they reminded me a bit of the device names from dmesg.

That concludes the setup. I have cat control, tx and rx in wsjtx and I’ve been making contacts thousands of miles away with my g90 and a janky speaker wire dipole in my attic. Fun stuff.

I hope this helps someone.

1 Like

Here are some of the pages that helped me:

1 Like

Nice write up. One thing you can do depending on the distro is you can set up the hotplug aliases so that every time that device is plugged in, it will get the same addressing. Makes life much easier. UsbDriveDoSomethingHowto - Community Help Wiki

1 Like

On KUbuntu 22.04 the serial port comes up as /dev/ttyUSB0 rather than 1. Thought I’d mention that. Great writeup otherwise!!

73 K7DGF Dave