New User of DigiRig has a problem or two or three (LOL)

Everything is untested/new, so lots to check. Using win11 10.5" tablet for first time, setup man-pack with FT857d for 1st time, bought DigiRig on Amazon for 1st time. Guess what … it is not plug and play (LOL). I tried WinLink/VARA and FLRig. Audio is pegged high on VARA and not correctable with win11 volume. CAT tests green & PTT works on FLRig but freq display jumps to random values. Tried 38400 & 9600 baud. This question is to get me started on troubleshooting which I will pursue step by step with the great K0TX documentation.
My question: I opened the DR to see how mine is set (hopefully not RS232). The options pads all appear unconnected in any configuration? (I thought I would need to cut the attenuator pads possibly to reduce audio level but there appears to not have a connection there to cut. My board says Rev. 1.9 and by the green stereo jack it says “Serial. 3v3”. Can I assume my board is set for serial at 3.3v levels (which I believe is correct for my FT857d)?
BTW, anyone know if some menu item in an FT857d can lower audio? Thanks.
I am 76 YO and I remember when radios were fairly simple, ahhh oh well (LOL).
73 Doug N8VY

@Doug_Bas The trace is very tiny to cut. With light pressure, passing a utility knife in the hair-width gap between the pads a couple times should sever the connection. You can confirm this both before and after with a continuity check from a multimeter on the pads. I performed this surgery last night on a DigiRig I was having issues with that I bought used and that solved my high-audio-level issues with a Kenwood TM-V71A.

1 Like

At this time the only variant available on Amazon is the default configuration (logic levels, 3.3V not connected, attenuator not enabled). Please follow the getting started guide and troubleshooting guide to make a gradual progress through issues.

Here are all posts related to FT-857D if you are looking for transceiver settings:

Thanks Brandon.

My win10 laptop is happy with audio levels. My win11 tablet is pegged and does not respond to level control in win11. Looks like cutting the trace is needed.

The ohm meter can also let me know how serial levels are set (or check voltage on stereo jack I guess).

Your help is appreciated

73 Doug N8VY

1 Like

Thank you.

That is just what I wanted to know.

When I use my win10 laptop, it is plug and play with acceptable audio levels, but moving to win11 on my tablet the audio is pegged and not settable by win11 controls. I will cut the trace for the 20dB attenuator. I could not even see the trace with a 10x loupe (wow) so trust the ohm meter😁.

Your documentation is excellent; well done. You have equaled the performance of my Signalink USB for half the price with more flexibility and way smaller. You certainly filled a needed niche in the market.

73 Doug N8VY


Thank you for your feedback.
Another thing that comes to mind: please check that AGC is turned off for Digirig’s recording device on your Win11 machine. When enabled, it renders the manual level setting useless.

1 Like

I had a problem with levels in wsjtx on Windows 11. Turning off AGC sorted the problem.

To find the setting (hidden my Microsoft)

Run the Control Panel
Hardware and Sound
Recording tab
Select properties for the DigiRig
Custom tab and deselect AGC

I have similar problem.

Using Windows 10 tablet (Dell Latitude 7212) flrig frequency jumps around.
Using Windows 10 laptop (Lenovo Yoga 720) perfect functionality with flrig.

Radio: FT-857D

I guess I will need to cut the attenuator trace as well.

BTW, anyone know if some menu item in an FT857d can lower audio?

Menu Mode
#37 DIG GAIN - Adjusts the audio input level from terminal equipment (such as TNC or PSK-31 sound card) during DIG (Digital) mode operation.
#72 PKT 9600 - Adjusts the audio input level from the TNC during 9600 bps Packet operation.