Not working now

Had the digirig working on Icom 718 since Feb. Took it off and placed on a 706 MKII G. Worked the VHF contest and POA with no problem. Back to the shack and it will not work rig control.
Tried the 718, and two 706’s. Using the same laptop along with two others. All with the same results. Also even tried another digirig. No joy there either.
It gives me a communications error. Timed out connecting to rig. I’m at the end of my rope. Any help appreciated.

This sounds frustrating. I am not familiar with either of these radios. I am not sure if the problem is rig control or audio or both. Are you saying that even if you switch the Digirig back to the 706 MKII G for VHF it does not work? Any screenshots of the communications error? What program is doing rig control? What digital modes are you using?

73 Constrainted

I am using FT8.
Any combination of rigs or laptops will not work now after working so good. Error is communications timed out.

1 Like

Thanks for providing more information. You are probably close to a solution.

OK, so now we know you are using the WSJT-X program to communicate with mode FT8. A good feature of WSJT-X is that you can name, save and clone configuration settings. Are you familiar with this feature of WSJT-X?

Rather than the File → Settings → General tab, the Radio and Audio tabs will have information about your radio and your soundcard selections. What do you see when you view those? Do the settings make sense? Relax and take it step by step.

Use Configurations to name and save the configuration for one and then the other radios you plan to use. That way you can keep them separate as you troubleshoot and then lock down the working configurations.

73 Constrainted

Understand that I had all the settings correct and it worked perfectly. Now it will not. I had a second digirig come in. Hooked it up and same issues with the rig control.
Again this is on all 3 radios, all 3 laptops, and all combinations of radios and laptops.

Yes, this sounds frustrating. You have swapped out radios, computers and soundcards and still no FT8. That leaves cables and software configuration, right? You can probably test continuity on the cables with an ohmeter. If the cables are OK, then it is software configuration.

Denis has published a troubleshooting guide which may help you test the Digirig to see if audio is coming out:

Troubleshooting Digital Modes – digirig

and another for rig control:

Understanding Rig Control Options – digirig

Sometimes if hamlib is not working, there is another way. For instance pulling PTT with RTS on a COM port.

73 Constrainted

To rule out Digirig’s hardware and cable you can do a loopback test on the serial port as shown here:

1 Like

Loop check completed and both cables are working as shown in you video. I type and it shows on the screen of the program.
I still have the Rig communications time out error. Any other suggestions?.

  • Make sure you connect the angled side of the CI-V cable (TRS) to transceiver’s REMOT or CI-V port. Straight end of the cable (TRRS) goes into Digirig’s serial socket.
  • You can check the configuration of the Digirig which should be set to CI-V when used with desktop ICOM radios.
  • Continuity of the CI-V cable should be: tip-to-tip, sleeve-to-sleeve, ring to ring1. ring2 not connected.