Potential RFI Issue

I’m using a Digirig 1.9 with the Digirig coiled USB cable, Yaesu HT cable, Yaesu FT5D and a HP Windows 11 laptop.

Every time that the Digirig keys up the radio when trying to send a Winlink Packet message, the USB port and audio devices drop out of device manager and I get a wave device error message from Windows.

I’m assuming that it’s an RFI issue. Does anyone else have a similar setup? Would the new shorter USB cable potentially solve the problem?

Thanks in advance!


Yes, this sounds like RFI which is quite common with HTs. Shorter shielded/chocked cable can help. You can add ferrites to the existing cable and/or switch to a better tuned antenna especially one with own ground plane. Some of this is covered in the troubleshooting guide and other posts.

1 Like

I had problems when I first tried the coiled USB cable - running FT8 with a KX3.
I fitted a small clip on ferrite to each and & the problems never returned.

Thanks for the replies. I’m going to try some ferrites on the existing cable. If that doesn’t work, then I will order one of the new shorter cables.

I put ferrites on the existing coiled USB cable, and it didn’t help. I have tried different USB ports and both the stock Yaesu HT antenna and a Signal Stick antenna without success.

I really want this solution to work, but I’m worried about spending any more money on it at this point.

Do you think the new shorter cable will make a different or should I give up on the Digirig working reliably with an HT?

Before you pursue RFI solution I would suggest confirming that the RFI is a problem. Do you have access to a dummy load or remote matched antenna? I’d give that a go at the minimum RF power to see if the issue persists.

Have you tried the lowest transmit power setting on the HT? If the problem goes away at low power then you know it’s RFI. I could not run full 5 watts from my FT-70DR or FT-1DR without RFI problems. Using a cable to move your antenna away from the HT may solve the problem.

1 Like

I finally had some time this weekend to continue troubleshooting. The problem did go away when using the Low1, Low2 and Low3 power settings on the FT5D. I was able to make my local gateway and send a message on Low3. I was also able to use High power with my external AirAntenna.

I think that confirms it is RFI. A little disappointed that I can’t use it at 5W with the HT antenna, but I usually have a roll-up J-pole with me, so that will become the deployment method.

You may be able to improve the situation with enough ferrites. The issue is that anything that is connected to your HT including your body act as the ground plain for asymmetrical vertical antenna.