Powerwerx DB-750 trouble shooting

I am trying to utilize a Powerwerx DB-750 I had laying around. From Denis’ recommendation I ordered the cable for the Anytone 778
AnyTone AT-778UV Cable for Digirig Mobile – digirig
When I try and transmit, I get a stuck PTT. I am using sound modem and Pin Point APRS. I don’t understand the test that keeps getting referred to on many of the stuck PTT posts. I do not see where I have an option for RTS in either of those software’s. Thank for any help in advance.

Update. It has to be something in Pin Point APRS. I tried Winlink and it worked just fine.

@Gunrunner99 That’s frustrating. I do not own the powerwerx db-750 radio, but it looks interesting. I did not even know they were in the transceiver business.

When I use PinPoint, I use the software TNC soundmodem. soundmodem by UZ7HO can control PTT via Digirig’s COM port. What TNC and OS are you using?

It sounds like you are already using the troubleshooting guide.

73 Constrainted

@Gunrunner99 Here’s the config window in soundmodem you need:

73 Constrainted

From the troubleshooting guide:

    1. test PTT function – when using hardware PTT line you can test it by shorting the signal to the ground on the jack that would go into Digirig. This should switch radio to transmit. Some HT cables have a PTT button which should also work the same way.

But since Winlink works, you have an indication that the problem is not with cable or connectors.

A more sophisticated test for the serial port hardware is:

  1. do a loopback test – although a bit technical, this is a reliable test to determine that the serial port’s hardware and potentially the cable are working. Open Digirig’s serial port in the console (I use PuTTY) and type any text – there should be no output in the window. Short TX and RX lines of the serial port on the end of CAT cable where transceiver would be connected and type some more text – you should see the text echoed back in the window. What happens here is your text input is being sent out as serial data to TX line which is then received by the RX line of the same port and you see the output of that.

But maybe the issue is with soundmodem config. I think you are very close to success.

73 Constrainted