PTT for Alinco DR-135TMKIII Radio

I am having issues with my Digirig connected to my Alinco DR-135TMKIII. I am building a VHF Winlink Gateway for my local area where there’s none in my area. So I got everything setup configured and connected the cable for the Digirig mobile to the radio and the other end into the device under the serial port. Configured the TNC software and cranked up the microphone volume setting in windows. The audio from the radio is able to go through fine but apparently when I try to run a PTT test apparently the radio can not PTT. So I tried going into the settings of the TNC software and changed the PTT port to EXT it then asks me to select the device HID but when i tried to select the device it’s not listed at all just all blank. I tried it on multiple PC’s and same issue it’s like either the radio or the Digirig device is not fully communicating with itself only partially which is only the audio. So can anyone help me fix this to get the radio to PTT to respond to whoever radio is calling my radio to make the communication going?

Software’s tried

Soundmodem Direwolf and VARA FM all nothing only can hear

Included images of the settings on sound modem and the layout of the radio

73 de KC1RKX

Cable connects to audio socket on Digirig.

i tried that and still wouldn’t PTT on my radio K0TX

also if anyone have the PTT file specifically for digirig that works for you feel free to either upload it here or if small enough talking less than 0.11MB enough that i can download through packets email at where one of the local hams in my area gave me a idea that the default PTT file might not supported with digirig

I see the cable has a conversion adapter. The stock DR-135 cable has male DB9 on the transceiver side and doesn’t need the adapter. What is the story of the cable you are using?

well i kinda messed up and bought the regular female to female RS-232 cable that i had to get a male to male adapter and did not see the word kenwood in the description when i bought the cable but now i am using the correct alinco DR-135 cable where it came in yesterday and still the radio wouldn’t PTT

Hopefully the equipment survived the experimentation. You can test as described in the troubleshooting guide.

have some good news and bad news i’ve done a few tests the PTT test through WSJTX by removing the cable from the radio and reconnecting it and testing the PTT on RTS it’s finally willing to PTT so i went to sound modem and tried it through calibration it’s PTT there too but very strangest thing that’s happening is that whenever I start the process’s on RMS packet which is the software that winlink uses to download the caller’s emails converts it into packets and send it to the caller and if they have emails to send out it does the opposite but uploads to send it out the radio is stuck to PTT position until I close out the RMS Packet software that’s the strangest event that i have ever seen have you had that case before with your product?

You are dealing with RFI. Please refer to the troubleshooting guide, “sticky PTT” section.

makes sense where it’s just a few inches between each other which is a work in progress already could tell by hearing the humming from the radio whenever i PTT without the card connected and the signal gone to a 35 through my local repeater which is still a work in progress right now i am just working on getting the exchange through winlink working out

1 Like

do you happen to know how to get the alinco DR135TMKIII to PTT through the sound card on a raspberry pi with direwolf at all? i tried a test call with my raspberry pi and moving my radio down to my HF shack and put it on a dummy load and it wouldn’t PTT at all

As far as I can tell there is support for PTT by RTS (Digirig’s method) in direwolf.
See Direwolf User Guide page #56.

good news I finally got the digirig to PTT my radio with direwolf on my raspberry pi and is somewhat responding to my test radio but i kept getting a message saying that the input is too loud and that most stations are at least 50 is there any way to change it that you know of in one of your tests or seen other operators change that setting in direwolf?

The preferred method to control audio is using some system’s audio mixer utility. Other operators shared here in forum how they do it in Linux/RPi. On Windows it is done in Sound Settings under Control Panel. If nothing else works, you can enable the hardware attenuator.

ok i will take a look and see what i can do on my pi to get it running as good if another operator is hitting my gateway right now i am in testing but by come hopefully sunday i will make it fully go live

good news just figured out what was going on I did not need to modify the card at all and it wasn’t RFI that was causing the card to tell the radio to stuck on transmit it has been the settings in the software that i was using that was causing all of that to happen but now it’s working fine and able to carry the activity successfully and comply with winlink’s gateway rules and regulations which is basically to keep the gateway running 24/7 and activity make communications with it at least once a day but thx for the help that you gave me past few weeks and if you are around the Taunton MA East Providence RI area feel free to use my gateway to get your emails if you use winlink thx again

1 Like