PTT issues. Multiple OS, multiple radios

TL;DR My Digirig won’t trigger any of my radios to transmit from any of my computers.

Hi all,

I’m having with PTT over multiple OS (Ubuntu, Raspberry Pi, and Windows 10) and multiple radios (Baofang UV-5XP, AnyTone AT-D878UV, and Yaesu FT-70D).

I purchased the DigiRig back in August and was initially successful in getting direwolf receiving and sending APRS. Hooray!

My setup was a raspberry pi 4, Digirig, and Baofang UV-5XP radio. I’m not a fan of the Baofang radios, but if I did something stupid, I’d rather let the magic smoke out of a $35 radio than my $300 radio!

My non-radio life caught up with me and I’ve not been able to get back to trying the Digirig until two weeks ago.

I tried the same setup (RPi->Direwolf->Digirig->Baofang). I was able to receive APRS without a problem. Transmitting, on the other hand, was a problem.

I watched the excellent troubleshooting video that Denis posted. Here’s what I found.

I started with continuity tests of the cable. This is the cable from digirig (by the way, I’m very impressed by the quality of all the cables I purchased). All the conductors match the wiring diagram on the product page. They all read less than an ohm of resistance. There are no shorts between conductors.

I don’t think the problem is the cable.

Testing PTT
In Denis’ troubleshooting video, he demonstrated using tweezers to short the sleeve and ring 2 while the cable was connected to a radio. To date, I’ve not been able to get this to work with any of my radios.

I’ve checked the tweezers, they measure less than an ohm of resistance when I check them. When I use the tweezers to short the sleeve and ring and measure the resistance between the sleeves of the connector side, I read less than an ohm (usually around 0.6 ohms in both cases).

However, every time I plug the connector into any of my radios and short the sleeve and ring, I don’t get the PTT on the radio to engage like I saw in Denis’ video.

I have a hand mic from AnyTone that works on both my AnyTone and all of my Baofang radios. When I measure the resistance between the sleeves of the connector of the hand mic when I press the PTT button, it again reads less than an ohm. And, when I plug this hand mic into any of my radios and push the PTT, the radio immediately starts transmitting.

From all my reading, when the sleeves of a Kenwood style connector (either my hand mic or the digirig cable) are both at or very near to ground, essentially shorting them, I would expect the radio to key up and start transmitting.

RTS Tests
Ok, so maybe the radios are smarter than I expect and want to have more than just PTT. So I tried the next test from Denis’ troubleshooting video, using wsjt-s “Test PTT” to test PTT. Unfortunately, every time I tested this, I was not able to trigger any of my radios to transmit.

Please note: I’ve tried all the above tests on all my radios and on all the computers I have. I have a Windows 10 laptop, a desktop computer with Ubuntu 22, and three different Raspberry Pi (a Pi 3, Pi 4, and a Pi 400). I try all of my HT on all three kinds of computers and OS.

So, what does the Digirig do when not connected to a radio? I unplugged the connector from the radio (and turned the radio off!) and measured the resistance between the sleeves on the kenwood connector from all my computers. When RTS is not enabled, the resistance reads as an open. That’s what I would expect. When I turn on RTS (usually from WSJT-X because it’s the most convenient) I see something I didn’t expect, the resistance between the sleeves is less than 1 ohm (about 0.6 ohm).

I have been reading through the forum posts and trying the suggestions there. Because I’m trying to get the Digirig running on my Raspberry Pi, and I did have a GPS, I made sure the “USBAUTO” is set to false and even stopped the gpsd. It didn’t help.

I’ve been reading through the manuals of all my radios and turning off everything that might cause problems. For example, I found a lot of CTCSS tone related settings on the Baofangs but I don’t see why that would prevent them from transmitting when I’m using the Digirig when the radios transmit just fine when I’m using the handmic.

If you have any suggestions of what I haven’t tried yet, I’m very eager to hear. Everything else I’ve done with the Digirig (mostly audio related) have worked great. I’m hoping I didn’t do something stupid to the Digirig for the RTS/PTT function. I would think that if I read a short between the sleeves when I have RTS enabled, that would be enough to key the radios.

Dave AE0EW

That is some extensive testing. Thank you for taking time to do the troubleshooting and write up the results. The PTT simulation by shorting ring2 to sleeve is the important bit here. There is no need to worry about OS, software configuration, transceiver settings or even Digirig itself until this part works. Do you use the black cable from Baofeng kit in your tests?

Hi Denis,

Good question. Yes, I’m using the black cable from the Baofeng kit. I’ve also tried the green cable with Chirp to test programming the Baofeng. That worked beautifully.


Does the black cable looks like it fully inserts into the HT similar to green cable?
Yaesu HT uses different cable; does the PTT simulation test work with it?

The black cable does appear to go in the same depth as the green cable. It also appears to go in the same depth as my hand mic.

I do have the Yaesu cable but I had the same results as the black Baofeng cable.

I have a question on the Yaesu cable. Does it make a difference which end of the cable is connected to the Digirig and which connects to the Yaesu? I wouldn’t think it would but I’ve been connecting the straight end into the Digirig and the 90 degree end into the Yaesu.

Dave AE0EW

It is very strange that you would have the same failure mode with unrelated cables and radios, so excuse me for confirming something that might sound obvious.

Just to confirm, the contacts we are shorting to simulate the PTT are on the Digirig’s end of the cable:


Re: Yaesu HT cable: the ends are not symmetrical. The angled connector goes into radio.

Strange at the very least. That’s what’s been driving me so crazy.

But, to confirm, I am shorting the two conductors you show in the diagram. According to the wiring diagram, shorting any of the others would not make sense.

The sleeve on the 2.5 mm connector is already at ground. We want to drive the PTT to ground potential. That’s the sleeve of the 3.5 mm connector. The PTT circuit in the digirig would drive that connector to ground when RTS is enabled.

I should be able to do the same thing by shorting the sleeve to R2 on the TRRS end of the cable. When I test with an ohmmeter, that’s exactly what I see. So I’m very confounded as to why it’s not working when the cable is connected to the digirig.

Also, thanks for the confirmation on the Yaesu cable. That’s what I thought but I don’t want to let the smoke out of my radio.

And, just to make this even more mystifying, I connected my Yaesu radio to the digirig and tried the PTT test using the WSJT-X software. To my amazement, the radio keyed up and started transmitting! Progress!

Then I tried Direwolf. I have a PBEACON statement in the config to trigger the radio to transmit. For the first time in two months, other stations have reported hearing my station. AE0EW-15 if anyone wants to check

But, in further proof that nothing is ever easy, even though I’m seeing the receive led indicating the radio is hearing traffic on the APRS frequency, direwolf isn’t showing that it’s able to decode any packets. That smells like a volume issue on the microphone level on the raspberry pi. But, I’ve checked alsamixer (and the correct sound card) and they are not showing as muted.

One step forward…


With Yaesu HT successfully keying up from Digirig/WSJT-X, it should also pass a simulation test (as a sanity check). Any luck with PTT of Bfeng from WSJT-X?

On windows there is a way to monitor the input from the radio by checking “listen” box in the properties of the Digirig’s recording device. With the correct defaults assignments this should patch the audio from Digirig to computer’s speaker. I believe I covered that in one of the videos as well as in troubleshooting guide. Not sure how the same can be done on Linux, but you can try with your PC for troubleshooting purposes.

1 Like

So when the WSJT-X test with the Yaesu was successful, I got excited and switched to my AnyTone radio. It didn’t work. So I switched back to the Yaesu to see if it would still work. It did.

I’ve switched to the BaoFeng but I’m getting strange results. When I do the WSJT-X/RTS test, the transmit led comes on but flickers rapidly (RFI on the PTT conductor?)

In other strangeness, when I had the Yaesu connected, direwolf reported no incoming packets, even though I have the microphone turned all the way up. The Yaesu was also the only radio to transmit a packet that was sucessfully heard and reported. With no changes to the audio settings (on my Raspberry Pi, by the way), I connected the Baofeng and direwolf is reporting all kinds of packet (and complaining that I need to turn down the audio levels), but no one is reporting hearing any packets from me.

I’ll try the same tests on my (wife’s) windows laptop. But it will have to wait until tomorrow. Work comes early in the morning. I know there’s a way to loopback audio on linux/RPi, but I need to lookup how to do it.

Thank you for all your help troubleshooting, Denis!!! I very much appreciate your hard work.


1 Like

Updated testing Info

I finally found some time to continue testing. I followed the video “Digirig setup for VaraFM with HT” for two reasons: first, the video was using a Baofeng similar to my own (I have a UV-5XP).

I followed similar steps

  • I did a reset of the radio
  • I did have to change the voice options from Chinese to English.
  • I then tuned the radio to one of the local NOAA frequencies (this was a great testing step because I’m always having to wait to see if I’m receiving anything)
  • I connected the Digirig to a windows computer (because it was easier to follow the video. I’ll figure out how to use the alsa loopback at a later time)
  • Windows recognized the Digirig as COM 6 and as a USB sound device
  • I then went to the Sound panel, set the name of the device to ‘Digirig’ for speaker and microphone, I also set the levels to 20
  • Under recording, I set the listen and had the sound sent to the laptop speaker
  • I was able to hear the NOAA radio broadcast through the Digirig on my laptop speaker! Yea!
  • I then started Vara FM and set the input and output devices. I also set the PTT to COM6 and RTS.
  • I adjusted the volume so I don’t overdrive the radio
  • I setup another radio tuned to the same frequency for a nearby Vara FM station
  • then tried the “Auto Tune” to do a calibration test

Here’s where things went wrong…

  • The PTT didn’t trigger the radio to start transmitting
  • Just to test, I tried pushing the PTT on the radio itself, that’s when the LED turned orange to indicate transmitting.
  • This is when I heard the transmission on my other HT.
  • Ok, so I’m transmitting, did I get a response? No, but I also wasn’t connected to my roof-top 2m antenna.

This is also the point when more things went wrong…

  • Windows flashed a message saying a USB device was no longer recognized
  • I went to the device manager and the Digirig was no longer showing in the Ports list or the Sound device list.

So, I’m still having the PTT problems and Windows lost it’s connection to the Digirig.

I unplugged the Digirig from the USB port on the laptop, waited a short time (typing this message) and plugged it back in. The device showed back up in the Device Manager.

So, still confused as to what I’m doing wrong. =(


It occurred to me to try the WSJT-X “Test PTT” while on the Windows laptop with the Baofeng.

I checked to make sure the Digirig showed up in the device list, it did.

I checked to make sure the correct COM port (COM6) and RTS was set, it was.

I tried the “Test PTT” button on WSJT-X and even through the button turned red, the transmit was not triggered on the radio. No error message was reported.

So far, the radio I’ve had the best luck with is my Yaesu FT-70D. So I set it up to test.

The WSJT-X “Test PTT” test works. Clicking the button triggers the radio to transmit.

I also tried the Vara FM tests from the video. I’m able to transmit and can verify via a separate radio (the Baofeng I’ve been trying to get to transmit).

I also tried running Vara FM from Winlink Express (my goal is to be able to send email via radio). I was able to get Winlink to start Vara FM. I was able to get the radio to transmit (verified by the other radio). I didn’t get a response from two different stations on the list retrieved via telnet. The closest station is 16 miles away and I’m connected to my roof antenna (the Baofeng is using a rubber duck).

The fact that I can consistently key the transmit on the Yaesu makes me suspect the cable with the Kenwood connector. Any other thoughts?


Re. cable: you can check the continuity of the connections by ringing it against the schematic provided in the product page (see last image).

Re. USB issue: What you are dealing with for sure is the RFI. The RF power from the radio disrupts the USB communication which kicks Digirig from the computer. See “sticky PTT” section of the troubleshooting guide for the info on diagnosing and solutions. As minimum I recommend using a short USB cable with ferrites while operating HTs which are notorious for RFI with out-of-tune antennas without ground plain.