Rigctl settings for Linux

Anybody successful using digirig with rigctl on Linux? I can see the device appearing as ttyUSB0 but don’t know the right settings to configure it further.

Ok, answering my own question, LOL.

rigctl -p /dev/ttyUSB0 -P RTS

However, the problem I had was that brltty would steal the device a few seconds after connecting. Which resulted in not being able to connect to it and the PTT being stuck high. As seen with

$ sudo dmesg | grep cp210
[    9.512532] usbcore: registered new interface driver cp210x
[    9.543674] usbserial: USB Serial support registered for cp210x
[    9.596031] cp210x 1-2.2:1.0: cp210x converter detected
[    9.629925] usb 1-2.2: cp210x converter now attached to ttyUSB0
[   11.020497] usb 1-2.2: usbfs: interface 0 claimed by cp210x while 'brltty' sets config #1
[   11.126768] cp210x ttyUSB0: cp210x converter now disconnected from ttyUSB0
[   11.126901] cp210x 1-2.2:1.0: device disconnected

This worked to disable brltty

sudo systemctl stop brltty-udev.service
sudo systemctl mask brltty-udev.service
sudo systemctl stop brltty.service
sudo systemctl disable brltty.service

Were you able to get this working ? I’m running into the same thing on Linux Mint with the Digirig.
73, Jamie WB4YDL

Yes, it worked for me. Trick was to ensure the tty was not hijacked. Once that was the case rigctl was able to drive digrig fine using the RTS setting

Thanks much ! Got it to work after autopurging brltty and using that rigctl statement. I set PTT to VOX in Vara FM.

The thing I run into now is that I have to go into Alsamixer each time I plug in the Digirig and turn off the AGC - it’s not persistent.

73, Jamie

Interestingly, now Alsamixer is behaving and AGC being off, stayed OFF !


73, Jamie