Set up yaesu ft-950

I am totally frustrated at getting Digirig to be set-up for Yaesu FT-950 and run FT-8.
This is entirely too complicated compared to Signalink.
I just don’t understand how to trouble-shoot why “Test CAT” does not work properly.
Error message reads from the very start…
Hamlib error: communication timed out
rig_get_vfo: returning -5( communication timed out
newcat.c(1005):newcat_get_gbi cehucet([5) communication timed out
read_string_generic called, rxmax=129
read_string_generic(): Timed out 26.669 seconds after 0 chars
read_string_generic(): Timed out 26.669 seconds after 0
charsnewcat.c(1565):newcat_get_vfo return ([5)communication timed out
read_string_generic(): Timed out 26.669 seconds after 0
Basically it just repeats the above over and over again with an occasional couple variations here and there later on.

In WJST-X’s Settings and its tab “Radio”, why is only the “Test CAT” available if Digirig uses PTT?
I have the correct entries in the tab “Audio” for the Soundcard; thank God I did rename them.
So what is wrong?
TIA for any help.
jerry km3k

The CAT control is the last thing to be configured. Please set the rig dropdown in WJST-X to “none” and ensure you have the basic functionality (audio in, PTT, audio out) working first. With that settled, we can deal with CAT control.

I recommend following the steps in getting started guide.

Rig drop-down set to “none” did not help.
It did lite up “Test PTT”; I clicked it; the box went grey but it never did anything; still waiting many minutes for a response about errors.
The 950 is not being keyed.

When I had the “rig drop down” set for Yaesu FT-950, my settings on tab “Radio” were:
serial port …com6
baud rate…4800
data bits…8
stop bits…2
hand shake…none
ptt method…rts
split operation…rig

I getting nowhere fast here.
jerry km3k

Let’s look at the device manager on your computer. Can you please supply the screenshot showing the ports and audio devices group expanded.

Also, please confirm that the MiniDin6 cable is plugged into the PKT port on the radio (highlighted in yellow) and the other end of that cable is plugged into Digirig’s socket labeled “audio”.

  1. Plugs in Digirig not connected properly; had to switch them. I thought i had it right.
  2. Then PTT worked.
  3. Then went from rig set at “none” to FT-950; that did not work.
  4. Back to “none” and now it won’t key.
    Cannot spend anymore time now.
    jerry km3k

RR, feel free to follow up when/if you are ready for more help.
While configuring CAT, make sure your radio’s baud rate matches the setting in software:

Menu item “CAT BPS” e.g.

192H == 19,200
384H == 38,400

With Rig set at “none”, there is no chance to set a baud-rate.

However, putting Rig to “Yaesu FT-950” and baud-rate set to the 950’s baud-rate, I get band changing capability.
So I think the next step is to look at audio levels.
jerry km3k

That is correct. Setting rig to “NONE” disables CAT control.
I suggest doing that to be able to focus on core functionality first and getting it running before dealing with CAT control. Once you have audio and PTT working and can get some QSOs in then change the selection and deal with port configuration.


Several days ago, running wsjt-x, I had the 950 decoding FT8 on 40m.
Using wsjt-x, I can key the 950 and hear the tone.

Then I wanted to run the sample file that wsjt-x has for FT8 but had trouble, so I made a post to the wsjt-x forum.
Rather than rehash that, I think it is easier to supply a link to that post to see what my concern is.
My post is at the bottom.,20,0,0,0::recentpostdate/sticky,20,2,0,97944571,previd%3D9223372036854775807,nextid%3D1680034185307656747&previd=9223372036854775807&nextid=1680034185307656747

The reply posts do not make sense to me.
My concern is relative to the fact I had the inputs to Digirig reversed (here I fault the written directions not specifying the color-coded connections as there is a level of anxiety and nervousness, dealing with a new product, that affect clear thinking.)
Has the Digirig been harmed by those switched cables?

73 jerry km3k

Digirig is quite forgiving when it comes to incorrect connections. I can reassure you that you are not the first person to attempt the wrong connection and the interface usually survives. If you have any doubt about the audio output you can use the diagnostics method covered in the troubleshooting guide: just plug in regular headphones into Digirig’s audio jack, activate the transmission in the software and you should hear the audio output on one side.

With audio output confirmed you’ll know that the Digirig is ok and you can refocus on other areas of troubleshooting.

I hear a tone.

73 jerry km3k

Then the issue is on the side of the radio. The software produces the tone and Digirig gets it out.
You can re-check the cable pinout, but if it worked before it is unlikely to be the issue.