Settings for Packet / Packet p2p

This can be an RFI issue. See “sticky PTT” section in the troubleshooting guide to confirm/fix.

I’ve been running Winlink with DigiRig and the FT-818ND - here’s my settings:


The following assumptions apply:

  • You have the optional “CAT.DLL” installed for SoundModem
  • You are using the correct COM port for your radio -
  • The Baud rate specified in this box in Winlink matches the rate you selected on the radio’s “CAT RATE” menu - which is menu #14 on mine - might be similar on yours.

The PTT method I think you should be selecting is “CAT”:


Good luck - and don’t give up !

Good details.

73 Constrainted

No - I mean, yes, I know - I initially posted something really dumb - look at the edited post above… I’ve been using Soundmodem all along… Don’t know what I was thinking initially ! Probably residual turkey torpor…

No problem, it’s all good. We will get his packets on the air!

73 Constrainted

1 Like

You can download that DLL from UZ7HO’s site - here.

That should enable the “CAT” selection in the PTT method dialog box…

1 Like

Okay - And Thank you. I was initially a bit confused having read the post via email at dinner. But it didn’t update after your edited your post. So took a moment to sort out.

That done, things should be relatively the same considering the FT818 and FT817 builds. Maybe the ‘issue’ isn’t with Soundmodem but with Winlink or - something.

I am trying to use Packet - or Packet P2P, I have a way to testing this rather easily over using HF.

Looking at Winlink these are my current Packet settings:

Setting as 1200 or 9600 doesn’t seem to make any difference. I did check Menu #14 and it is set to 38400, so that matches.

I do have both PTT.dll and CAT.dll in the directory:

  • image

@g.jacobse 1200 Baud, not 9600, from my experience.

73 Constrainted

Hello - Looks like you’ve done some debugging here and maybe the problem is solved…

An observation: with Direwolf (a SW TNC like Soundmodem), one is required to add a statement in the config file that looks at the USB/Virtual Serial port RTS signal for PTT to activate for DigiRig. I suspect this is also required for Soundmodem to initiate PPT in the 817. Not sure of of the correct syntax, but SoundModem’s config dialogs should have a PPT section, and RTS enable there may help.

The only thing I noted is you might try switching the TNC mode to “NORMAL” - as recommended in the “official” Winlink Setup Guide - definitely worth a read - Link here

Other than that, the Winlink setup looks good to me…

Last night I tested my setup (just to confirm it still works) - and here are my current settings that work:

Of course - a few items will be different like folder locations, com port numbers, etc…

I’ve also noted in the past that generally, after making config changes you should probably restart the app - but not sure if it matters to Winlink… :slight_smile:

If you still have no joy, I’m thinking the issue has to be between the Digirig and the radio… Check both the data and audio cables from the Digirig to make sure they are fully inserted into the radio - and verify the radio is in “packet mode” - I’ve forgotten in the past - and kicked myself once I realized it. I know Winlink will change frequencies if you select a different site - but it doesn’t change the radio mode… So many little things that can trip you up…

First let me say thanks to all those who have read this thread, and those offering suggestions. Little did I know it may not have any to do (or little to do) with settings. Though Seeing as it wasn’t keying the radio it did.

Once I got the radio to key the radio, I wasn’t getting audio on the radio I was using to monitor - Must be an audio setting issue. Or a Mode setting. And yes it was a tad bit of all.

Radio needs to be in PKT Mode - easy there’s a button for that. And - wait,… why is it changing the transmit frequency? face palm well,… that’s interesting.

Some how the radio was not only set with a - offset, it was set to T-Sql. Successful connection to a station twenty-five miles away, and successful transfer of message.

I will make note of the settings and add them,… There is still some turkey left to be had.

Happy Thanksgiving.

1 Like

@g.jacobse Congratulations on your solution! Thanks for sharing your results here.

73 Constrainted