Settings for Packet / Packet p2p

Technical Details:
Yaesu FT-817, DigiRig (COM3) WinLink Packet P2P using Soundmodem

Having a tough time getting WinLink configured to use the DigiRig and the FT817.

I can get the setup to receive, but it will not transmit. I am certain it is a simple matter, but after hours of reading over the last three months, I have not come across the information that would get me running.

Working with computers - I am certain it’s a simple matter, but have yet to see what it is that is incorrect with my configuration.

I will be looking over some suggestions (Digirig setup VaraFM on a FT897D) and seeing if this information is helpful as the 897 and 817 are similar.


That’s frustrating, but now that you are here, I think you are close to success. I do not have the Yaesu ft-817, but others have commented here. If you follow yaesu-ft-817 topic link you will see.

There is also the troubleshooting guide.

You may see an answer right away.

If not, come back with specifics like which computer OS, your driver for the CP210x USB UART device, your configuration tab for PTT in soundmodem, test for RFI, etc.

73 Constrainted

Thank you for the reply @Constrainted - I believe I have gone through most of that, and Google Searching as well.

Here is what is in use:
Windows 10 22H2 19045.3570
DigiRig is COM3 (Silicon Labs CP210x USB to UART Bridge)
USB C to USB C cable
FLRig Connects and cycles radio correctly.

SoundModem Settings for SoundCard

1 Like

WinLink P2P setup

1 Like

Is is only PTT that doesn’t work or CAT control too?
Can you also show what’s under “Advanced PTT settings”?



The WinLink Packet P2P session shows this as well:

*** Starting peer-to-peer packet session…
*** Launching C:\HamRadio\soundmodem\soundmodem.exe
*** Soundcard modem is running.
*** Initializing KISS; port COM3; 38400 baud
*** Initialization complete
*** Opening serial port COM3; 38400 baud; KISS
*** Unable to open COM3

The settings in the latest screenshot pertain to CAT control, not to PTT. Is that what shows up when you click “Advanced PTT settings”?

Also, Unable to open COM3 is an issue that needs to be settled first.
Can you share the screenshot of the device manager with ports group expanded and visible?


When PTT Port is set to CAT, Advance PTT Setting lists those settings - yes.

Are there other options for PTT other than CAT?
Does advanced section look different when non-CAT PTT is selected?

Digirig supports PTT via CAT command, but I’m trying to see if there is PTT by RTS option hiding somewhere there too.

What connections are you using between the Digirig and the FT817?

I assume you are using the 6-pin MINI DIN for the Audio in/out, but what are you using for CAT CONTROL? Do you have a cable linking to the ACC port from the DIGIRIG or direct from the PC to the ACC port?

If not, then you will need to get the digirig to do PTT through the 6-pin MINI DIN, but you will also be missing out on CAT Control for frequency management of the radio.

USB-C from the laptop to the DigiRig, then the two cables (Audio / Serial) from the DigiRig to the Radio. No cables direct from the laptop to the radio.
And maybe my understanding of how the software(s) control are incorrect. I had the expectation that FLRig was needed to control the radio.

With these settings, if I change RTS from OFF to ON, the radio goes into immediate Transmit.

Doesn’t look like FlRig is involved in this setup since you are selecting radio’s profile directly.
The interface is misleading if CAT settings dialog is attached to “Advanced PTT settings”.

I’ll circle back to previous question: Does advanced PTT section look different when non-CAT PTT is selected?

In this arrangement - no FLRig is *not * in use.

Using EXT:

When Using COM3

Do you get the PTT with COM3 selected as PTT port as in last screenshot?

No, It is greyed out.

I’m referring to the actual keying up of the radio with that option selected.

Does the Radio transmit with that setting? No. it does not.

Try with “Dual PTT” checked. That worked out in this post:

Dual PTT keys the radio, but does not release it. Which of course isn’t what we want to do.