Solution: how to force sound card order on RPi

Forcing the order of your sound cards can solve some software issues on the Raspberry Pi. For example: if you have to constantly re-select USB PnP Sound Device Audio on Fldigi after a reboot, you may benefit from forcing the sound card order. After hours of scouring the internet and wading through a sea of bad information, I was able to locate the solution posted here by username ernstkl.

The info we need is toward the bottom of the post.

sudo nano /lib/modprobe.d/aliases.conf

Comment out, or delete the existing line about USB sound cards.

Add the following:

options snd_usb_audio index=0
options snd_bcm2835 index=1
options snd slots=snd_usb_audio,snd_bcm2835

ctl+x, Y, enter to save
sudo reboot

Verify new sound card order with aplay -l
If the Digirig PnP USB sound card doesn’t appear, you probably typed something wrong in the aliases.conf file.

This will force your Digirig to index in the zero spot, and the headset jack to go into the 1 spot. The Digirig will stay in that place so that it doesn’t randomly switch spots following a reboot, and so Fldigi will know where to find it. I have made this work on the Pi 2B, Pi 3B, Pi 3B+, and Pi 4.

1 Like