Transceiver Not Responding message from flrig when trying to connect

I have a Yaesu 857D with a digirig being driven from a Raspberry Pi 4. I am using flrig to connect.

Combination works fine when I use my windows machine instead of the RPi.

Combination was working. But then started to give a Transceiver Not Responding message on startup of flrig. Failed intermittently at first. But now fairly consistent. Perhaps one time in ten it will work (various combinations of disconnecting and reconnecting the digirig to the RPi, turning off an on radio, rebooting - and using init on flrig). I haven’t come up with a sequence that dependably gets it working again - though eventually it (usually) does.

The device appears in response to this ls command:
pi@RadioPi:~ $ ls /dev/serial/by-id

a couple of other notes:
I have been configuring various things - primarily getting things working with build-a-pi - so it is possible that I tweaked some setting in something. This is certainly not a case of a) it worked b) I didn’t touch a thing c) it stopped working… So it may very well be something I did
My gps dongle stopped being recognized by the RPi. So perhaps I have a glitch in USB sockets on my RPi…

thoughts on where to look next?

The daemon for your GPS dongle probably thinks that Digirig’s COM port is the GPS because both use the same UART chip. Check these posts.

This looks promising - thank you. Tried the change to gpsd file (USBAUTO=“false”). I will have to see how it plays out over some reboots - and trying to open flrig…

1 Like