Trouble Setting up Baofeng / Digirig / SoundModem

Hello Everyone,

I’m trying to get set up for Winlink using my Baofeng-f8hp, the Digirig and the Digirig cable. I have studied the “Getting Started” section of this site and have watched numerous Youtube videos including the Ham Radio Crash Course set up video https://www.youtube.com/watch?v=-sherRk674k along with numerous others.

I can’t seem to get the system to work. No modem sounds are produced and the Baofeng PTT does not appear to be getting triggered. I checked continuity on the Digirig cable and it appears to be working properly. I also tried listening for modem sounds directly at the Digirig and got nothing. Lastly, I also tried pulling the usb cable as far away from the computer as possible to reduce RFI interference.

I am able to get a green waterfall and everything, but the PTT is never triggered (and modem sounds aren’t pushed from the Digirig).

Please find below screenshots of my settings. Yes, I triple checked that it is on the correct Com Port (14) in device manager.

There are a couple of weird things that are happening. For instance, the “Output Volume” and “Input Volume” in the SoundModem app don’t work (if you click on them, nothing happens).

The SoundModem version is 1.14. Winlink Express is version 1.7.12.0 I have tried it on two different Windows 10 machines and one Windows 11 machine. I also tried installing Vara FM and am not getting a PTT signal (or any connection).

I have confirmed the Com port on each computer in the Device Manager. I have also set volume levels appropriately as indicated in the start up guide.

If you have any advice, I would greatly appreciate it!

Thanks,

Charles
KK7MZP

P.S. Another weird thing is that the “Advanced PTT settings” button in the Sound Card settings tab is greyed out and doesn’t work as well.

That’s frustrating! One of the first problems I solved with my Baofeng for digital modes was pushing in the K connector all the way to make contact. The boot was obstructed by the plastic on the radio unless I pushed. Reseat the audio cables, too, just to be certain. Are you using cables made by K0TX?

Good you double checked COM 14! You are close to success!

73 Constrainted

Thanks for your feedback. I double checked that the K connector is pushed in all the way based on your posting in a different comment. I also trimmed back the plastic a little just to make sure that it was making solid contact. I am using the Digirig cables (black for audio).

One of the weird things is that I am not able to hear modem sounds coming from the audio port with headphones as well. I’ve used multiple different USB cables too to make sure that they are data passing cables and not just charging cables.

Charles,
If Digirig’s devices are detected by the computer, you can move on from USB troubleshooting.
This might sound silly, but make sure you plug all black cable into Digirig’s audio socket.

Next try monitoring the audio coming from the radio (need squelch opened) as shown here:

Thanks for your message. I am now able to hear the modem sounds coming from the Digirig. For some reason, though, the PTT on the Baofeng is not being triggered, so nothing is going on the air. I have the squelch on 0 and am getting a green waterfall, so the audio seems to be set properly. Whatever signal is required to trigger the PTT doesn’t seem to be making it to the Baofeng (or something on the Baofeng isn’t picking up the signal). To be sure it wasn’t my first radio, I got another one and tried it to no avail as well.

Here is a screencast of me trying out the settings. Please note the settings in SoundModem where the volume up and volume down buttons don’t do anything. The advanced PTT button also is greyed out and doesn’t work. I have confirmed that Com14 is the com port for this device as well. It looks like everything but the PTT getting triggered on the radio is working.

Capture

I just tried testing PTT with WSJT-X (WSJT Home Page) to no avail as well.

image

image

That is frustrating. The error message says something is wrong with the audio device. What does the audio panel show?

73 Constrainted

Thanks for looking at it. Here is the error the audio panel shows:

@KK7MZP Yes, that error message shows the details. Another panel, the Audio tab, lets you see which audio devices WSJT-x is using:

These are not Digirig audio devices in my example. What does yours show?

Following the guide, Troubleshooting Digital Modes – digirig will allow you to isolate and solve each issue step-by-step.

73 Constrainted

1 Like

I’m in a similar place. Trying to get Winlink Packet to work with DigiRig and an HT (D878UV plus in my case) . Struggling with PTT. Meanwhile other things, for example VARA FM, seem to work just fine.

I have read through many threads here trying to match settings, grabbed copies of the N1SPW guides and followed them…only to get stuck on trying to get the radio to key up. I’m using exclusively DigiRig cables (PC → DigiRig USB with the dual ferrite cores and Kenwood style radio connector, and yes, plugged into the “audio” socket).

What I see is that the radio will key up for just a moment (the red TX LED comes on then goes right off again). If I manually hold the PTT when starting the winlink packet session, I can hear the radio transmit tones (monitoring via SDR gadget).

I’ve tried just about every combination of PTT settings in soundmodem devices config, starting with just using COM3 (which is the correct port, clearly so since VARA FM works with it) and also trying the EXT setting (it did let me select USB sound but didn’t let me use -2/-3/-4 choices in the drop down list whatever those mean). I’ve tried the dual PTT box and the reverse pins box… Only the COM3 choice even attempts to key up…it just doesn’t hold the PTT long enough.

Any clues or ideas from people that have this kind of combination working would be much appreciated.

That sounds frustrating. There is a section in the guide, Troubleshooting Digital Modes – digirig

Sticky transmission, Errors on Transmission

That may explain what you are seeing. I had success with the Baofeng when I started using remote antennas.

73 Constrainted

Thanks – I had read that. I was experiencing the sticky PTT (keys up, doesn’t shut off), even with VARA FM, when trying to use a longer USB cable to separate the radio and the PC/DigiRig more…but that cable had no RF protection. Reverting to the supplied DigiRig cable with the dual beads sorted that problem and VARA FM now works, packet/soundmodem not so much.

The equipment is the same and physically placed the same when I try Winlink VARA FM and Packet sessions. Given that VARA FM can key up and release the radio no problem, I have to think the simplest explanation is something with the packet session and or soundmodem settings, not the cables or the power level or the antenna per se. But, FWIW, reducing the TX power (which I was doing while testing initially before making VARA FM connections) didn’t change the symptoms. A remote antenna might help but right now all I have is the HT and a SignalStick antenna. I was hoping that this portable set up could be made to work, but perhaps that’s a bridge too far(?).

[packet is desirable for me because where I am there seem to be packet capable stations at higher elevations as compared to less choices for VARA FM connections.]

My set up shows it using the Digirig inputs and outputs.

I’m thinking the issue might be RFI interference with the USB cable. I’ve ordered one of the Digirig cables with ferrites on it. It is supposed to arrive on Friday, so I’ll let you know what I find after using that new cable.

1 Like

For what it’s worth, I tried setting up Direwolf to try this as well – wouldn’t you know it…same symptoms: it keys up the radio for a very brief moment and then lets up on the PTT well before any audio gets transmitted.

Just for funzies, I set the audio device to an actual sound card and when I do that, the audio is generated for the outbound transmission, no problem.

So, if only the PTT would work properly I think everything else is set correctly…

Still strange to me that VARA FM seems to handle this no problem with the Digirig but now two packet modem software cannot. That it works at all with any software says that using the Digirig with these packet modems should be possible because it’s just the device control aspect that isn’t working right :confused:

Just to give everyone an update. Denis was kind enough to help me troubleshoot the issue and we determined it was a bad cord (with intermittent loss of ground). He sent me a new cord that arrived today and I was able to send out a message on the first try. Thanks to Denis for helping me get it up and operational.

For future readers – if you run into this issue like I did, try testing continuity in multiple different positions with the cord. I was getting continuity when the cord was laying flat, but lost it when it was connected to the radio.

In any case, I’m excited to have this for my Baofeng radios! Thanks Denis for your help.

1 Like