Troubleshooting G90 serial CAT

Confirm the settings
If you run into any issues setting up G90’s serial CAT control with Digirig, then try making it work with Xiegu’s native blue USB cable first.

image

This will confirm that the software and transceiver are configured correctly. You can then swap out the connection to Digirig and change the COM port number in software preserving all other settings.

Select correct COM port
Make sure you use correct COM port number. When interface is connected to computer via USB the Digirig’s port should appear in the Device Manager with “Silicon Labs CP210x USB to UART Bridge (COMx)” label. If there is an exclamation mark next to it then the driver needs to be installed/updated.

Check the connection
For G90’s serial CAT use 3.5mm TRRS to TRS cable. Straight TRRS end goes into Digirig’s serial port, angled TRS goes into the socket with person icon at the side of the head unit.

image

Disable hardware flow control
Additionally to PTT via CAT, Digirig supports a hardware PTT driver via RTS signal of the serial port. Disable hardware flow control and handshake features if the radio switches to transmit the moment you connect the audio cable.

Loopback test
Open Digirig’s serial port in the console (I use PuTTY) and type any text – there should be no output in the window. Short TX and RX lines of the serial port on the end of CAT cable where transceiver would be connected and type some more text – you should see the text echoed back in the window.

image

Find additional troubleshooting steps here.

I’ve went through the troubleshooting steps, but the CAT control still isn’t working. USB cable that came with the Xiegu functions as expected, but when switching to the digirig only audio works. I’ve verified my COM port, and preformed loopback test. I did receive the echo back in that test using Digirig cable. What other steps can I take to get everything working?

Here’s another test that excludes any software configuration specifics:

  1. double check Digirig’s COM port number

image

  1. prior to powering up the radio connect only the CAT cable and open the port in console at 115200 baud

image

  1. boot up the radio

This is what I get in the console:

image

Do you get the same output?

This is all I get:

Not a whole lot…
A successful loopback test earlier doesn’t reconcile with what we are getting here.

I’m sending a replacement Digirig which I’ve pre-tested with my G90 as well as a return label for the original unit so I can try and reproduce the issue on my end.

Thank you for your patience with this.

1 Like