TS2000 cat works, but no audio

I’m using a TS2000 and a digirig mobile configured for RS232 and the Kenwood DB9 cords connected to the back of the radio.
I use Omnirig to set my device (as i also like to use Log4om simultaneously).
Cat control works just fine. But on WSJT-X I recieve no signals in the waterfall and the radio won’t key up if I try to tune it.
Below are some screenshots of my settings. Any thoughts on how to fix this?


Thank you for sharing working CAT control settings for TS-2000.
For audio, please start with the basic troubleshooting steps as shown here:

Please keep up posted on your findings.

Thank you for responding! I tried to run the tests as shown in the video. The device is recognized by the computer. The digirig also shows a signal when i tune the radio. The loopback test didn’t work. I connected pins 3 and 11 (as shown in the TS2000 manual), used the tune function in WSJT-X and nothing happend. I also tried pin 1 and 11, which should be the secundairy channel output, and again nothing.