USB Audio Device vs USB PnP Audio Device

Hi All,

Just started playing around with my new digirig.

In all of the docs, it mentions that it should show up as a USB PnP audio device. On all three of my laptops (2 win 11 and 1 win 10), the digirig shows up as a generic USB audio device.

It does work, mostly. Works fine with vara fm on UHF – VHF is another story; all sorts of weirdness there (I’m guessing RFI problem, so have a ferrite usb cable coming)…sometimes the com port will vanish from the device manager upon transmit and sometimes it won’t, but the radio will be stuck transmitting. With packet, direwolf will timeout (and shut down) waiting for input from the audio device.

So, my question is does digirig need to be enumerated as a USB PnP Audio device (vs USB audio device) to work properly? And if so, what is the magic to make that happen?



That’s frustrating. I agree, it sounds like RFI. You mentioned Win10 and Win11 OS. Could you give more details about your radio, antenna, USB cable length, audio/PTT cable length?


73 Constrainted


Tried it on a couple of the Baofengs I have laying around (I actually have a Yaesu coming today :)). Signal stick. The USB cable is probably about 2 ft long and the audio/ptt cable is the standard Baofeng digirig cable which is a coiled 1.5 ft long or so.

Problem happens on three laptops; 2 with windows 11 and one with windows 10. None of them have the digirig showing as a USB pnp audio device (just generic usb audio device).

I have a Digirig Shielded Short USB-A to USB-C Cable with Ferrites coming today. We’ll see if that does the magic.

And again, is it a problem that the digirig isn’t showing up as a pnp device?


Tim, that is not a problem.
There is a difference in device description between earlier audio codec (CM108AH) and the update in recent production batch (CM108B). The functionality is the same.

Please keep us posted on your progress dealing with RFI which is quite common with HTs.

@KA7BZG Thanks for those details. I finally had digital success with my Baofeng- HTs when I started using remote antennas: rollup J-pole type with ferrites and 1/4 wave magmount type. It is good you already have the ferrites on the cables.

73 Constrainted

Thanks for all the info.

Played around a bit more (while listening to work calls :)) and I found that…

With my UV5R (no matter what antennae), it doesn’t matter what I do. Not happy with 2m, nor really happy with packet. Seems to be happy with vara fm and 70cm.

I have a UV17R. With the stock antenna, 70cm is fine. 2m is flaky though - works sometimes and sometimes not. When it doesn’t work it doesn’t seem to be causing the COM port to drop out, but the behavior (except for that) appears to be the same.

HOWEVER, the UV17R with the dual band signal stick seems to work pretty good. And this is without the chokes (the cable hasn’t arrived yet).

Both of these guys are being relegated to backup duty – Yaesu VX6R and FT60R should be arriving today (building EmComm bag–doing NET ARO, then ARES, etc.). The digirig cables come later in the week. We will see how all that will work out.

I’ll also try out the UV5r on 2M when the choked USB cable comes and will report back…


1 Like

Tim, so if I understood correctly an older digirig will show as a PnP and a new one will present itself as a generic USB device? I bought one last year for my Icom and it works great with FLrig. However with the new one I bought 3 weeks ago for my G90, it shows as a generic USB device and I’m unable to get it to talk to FLrig. I’ve followed the videos you’ve suggested from K8MRD and no joy. Any help would be appreciated. PS I’ve setup up separate profile on my PC just to run the G90.

73 Eric N0ZHD

The sound card in Digirig will identify itself to computer as either “USB audio device” or “USB PnP Sound Device”. The rest of the setup is the same.

FlRig configuration mostly involves the settings for the serial port. There was no change in that department between the variants of Digirig. For serial port troubleshooting please check out this video:

Dennis, thanks for the reply. I checked for the loop around and it worked. However I’m am still getting this error, it’s possible I’m missing something. Thanks for the assistance.

Eric N0ZHD

Some of FlRig versions had bugs.
I would try direct configuration in WSJT-X to see if you can pass CAT test there first to rule out software side of things.

Dennis, Thanks for the advice and I will try that.