Using digirig mobile with FT-891 for JS8Call without CAT

I’ve hit a wall configuring JS8Call to run with my Yaesu FT-891. I’m running windows 11, the digirig mobile, and connecting without the USB connection as suggested by KB8VBR in his video on running FT8 through wsjt-x with the same setup. I have that working fine.

I’m struggling to set up JS8Call without the USB connection to the radio. I’d like to have it run without CAT control, just using RTS for PTT just like on wsjt-x, and then setting the VFO on the FT-891 by hand. When I set the options the way it seems appropriate, it has received some signals, but after a short time I get a “Rig Control Error, would you like to reconfigure” message. So, it seems to be looking for CAT control even though I think I have it set to RTS.

Here are clips of my settings:

The com port is set correctly and I’ve tried both CAT RTS ENABLE and DISABLE on function setting 05-08 on the rig.

I’m guessing I’m missing something obvious, but I can’t find it.

Thanks for any help.

1 Like

That is great that WSJT-x is working.

For JS8CALL, have you tried Radio → Cat Control and setting Rig to None? (You are not using CAT control, right?) Then Radio → Rig Options set PTT Method to RTS and set the appropriate COM port, COM5, in your case, I guess.

73 Constrainted

I believe we have a win! Setting the rig to “none” allows me to test PTT which works and allows the Tune function as well from the main screen. I was operating under the apparently faulty assumption the program would still need some type of info about the rig to know what to do with the RTS signal. Thanks for your help, Contstrainted. The program seems to be at least behaving correctly now.

73, Jeremy

1 Like

Great! Thanks for reporting your success back to the forum!

73 Constrainted