VaraFM Support for Baofeng using Digirig

I bought a Digirig combination from GigaParts marketed specifically for Baofeng HT, which I already got working very well on SignaLink, but wanted to pursue a Digirig solution which seems to consume less power. Trouble from the start. Black cable was connected to Audio port and a USB Silicon Labs driver was installed for a Windows 10 Com port. The VaraFM PTT was set to Com 3 and the RTS box was checked. Has ANYONE ever got this working on VaraFM? It will transmit a burst of data for a ping or autotest on the Sound Card menu, but never produces a passing result.,,,20,0,0,0::recentpostdate/sticky,,,20,2,20,87641230

I found this topic and got clued in on the level problem mismatch. it’s pretty severe.

Yes, the level settings are critical. More on this topic here:

Digirig is connected to the radio’s speaker port (as in case of HTs), you will need to open the squelch and adjust the audio level with the volume knob.

Find the received signal indicator, scope or waterfall. Using the level slider from the previous step, adjust the level so it is a touch below the overdrive territory.

1 Like

I’m trying to figure it out. I do think it’s something to do with the tone. I’ve read the bofang manual and tried many different combinations. No luck.
If you figure it out please post it

Make sure AGC for the digirig soundcard is off in Windows sound settings.

There are a few different pitfalls you can run into when using a Baofeng and a Digirig. In my experience, the most common is pretty easy to fix though. Make sure you use a USB cable between the Digirig and the computer. Most serial to USB cables do not have ferrites for filtering out noise. Adding a cheap 7mm snap on ferrite to each end of the cable solves a lot of problems. Most often you’ll experience a “stuck PTT”, but I’ve seen it fix many other common issue as well.

1 Like