When red plug is inserted radio goes into transmit

Using the USDx radio. When I plug in the red plug into the mic the radio goes into transmit. If nothing is connected to the other end of the plug and red plug is inserted into mic the radio goes into transmit. If I connect the mic normally it works as it should. Is this a bad cable? The computer receives the signal normally from the speaker jack and the waterfall looks as it should if I leave the red plug disconnected.

Are you using a radio certified by Manuel DL2MAN? I am having success with Digirig and 40m digital modes with a radio certified by him.

73 Constrainted

I am having the same problem. Radio is from a verified seller on ebay and the cable is from digirig. When the red cable is inserted the the radio automatically goes into transmit. Any idea of the cause and solution? Thanks

Please try the solutions suggested in the troubleshooting guide. Follow up with the configuration details if none worked.

Same issue here. I’m using an (tr)uSDX, certified by Manuel, DL2MAN, cables from the Digirig shop. Tried almost anything in the mentioned article. Any hint towards a solution is greatly appriciated.


This sounds frustrating.

In my experience with the truSDX, firmware 2.00i, if the Menu 2.6 Keyer Mode is set to Iambic A or B, the insertion of the red cable causes the radio to transmit. Menu 2.6 Keyer Mode must be set to Straight.

73 Constrainted

It is really frustrating, but thanks for your response anyway.

My radio is on Straight Mode all the time. I tried a different (tr)uSDX, on a different Laptop, also tried with another (Beta) Firmware - no luck. I have no clue what to try next…

I did some further testing, and found the Digirig to be unusable in combination with the famous (tr)uSDX Radio. What I came up with, is a simple (and cheap) Sabrent USB-Sound card plus two AUX-Cables (cheap as well). This setup works out of the box, without any frustration and has the same cable (messy) setup as the Digrig has (== 1. USB for CAT Control, 2 Audio in and output). I’m going to further tweak this setup and make it ready for field usuage.

Conclusion. Digirig is a great solution for a number of radios, unfortunately not for the (tr)uSDX.


Glad to hear you found the solution for your digital modes configuration.
Do you know the model/revision of your (tr)uSDX? This report conflicts with overwhelming number of successful confirmations. This can be just a configuration issue. E.g. the fact that you can get away with a general purpose sound card suggests that you don’t use PTT by RTS which is Digirig’s primary PTT method. If PTT is not configured correctly it can cause the symptoms described in this thread. This topic is extensively covered in reference materials.

I am glad you found a solution with the Sabrent audio card and USB cable for CAT control.

Digirig is a great solution for digital modes on the truSDX. It works “out of the box.” I use it several times a week for Winlink Vara HF, and occasionally for other digital modes like Thor22 this past weekend.

73 Constrainted