Win10 Device not Recognized

Got my DigiRig today and when I connect it to my Win10 PC I get the error this device not recognized.

Screenshot 2022-09-15 005845

I’ve tried it again this morning and sometimes I plug it in and some times it recognize the device, some times the error.

When it does recognize it give me two sound devices.
Screenshot 2022-09-15 132859

I disabled the “Audio Device” one in device manger and got fldigi to tx through the “Sound Device” device. However I don’t know if it is the digirig itself or the USB cable but if I touch/move the setup then my PC loses the connection.

This can be a flakey USB port on the PC or bad cable. Do you happen another computer and/or USB cable to try ruling those out?

Also, is the COM port detected as expected?

Yes, the com port is there and I got fldigi to use it for ptt. Tried a different port and it ran stably for an half-hour – then I unplugged it.

Do I understand it correctly that everything (COM and Sound) works correctly when you plug to another USB port?

Yes that is correct.