Windows 11 - DigiRig COM port not showing up

My new DigiRig 1.9 (for a TX-500) arrived today. When connected to Windows 11, only the two sound devices show up in device manager. No COM port.

I have all the latest drivers installed (CP210x_Universal_Windows_Driver), but can’t get the COM port to appear (there are no devices listed under ‘Other devices’ in device manager list which you would normally get with a driver problem).

Does DigiRig need to be connected to the TX-500 for the COM port to show up? Still waiting for delivery of mine so can’t test.

Tried two Windows 11 machines and multiple USB cables.

1 Like

No, the COM port should detect as soon as you plug Digirig into USB.

It’s unlikely going to matter since the sound card is detected, but let’s try it on the different computer before we go ahead with arrangements for replacement.

1 Like

Hi, I have now tried on two Windows 11 machines and a Windows 10 machine. I only ever get the audio devices, no COM port.

1 Like

I have loaded this on two laptops. 1 win 11 ASUS the other win 10 DELL i7. Neither loaded the com drivers. I had to download them and manually load them. Then the com ports showed up. Audio drivers showed up on plugging in on both. systems

Alan WA1AR


I am having the same problem. My digirig works fine on the windows 10 machine but not on the windows 11 machine. I looked in the device manager and no port is listed for the digirig. On the windows 11 machine the receive is working fine but not able to transmit and it says rig control errror. It does not assign a COM port. Can you help?

I’m using Win 11 x64 on my desktop and the COM port does show up as soon as I plug in the digirig. It works with Direwolf software TNC triggering PTT. I was also able to trigger PTT with hterm terminal program when the “RTS” button is pushed.

I did not have to load a driver for the digirig. I plugged it in and it worked straight away.

1 Like

Just to let you know; I have had the unit replaced and all is working fine now.
Thanks for the help.