Winlink Express PTT Vara issues

About a week or two ago I bought a digirig mobile with logic control and Baofeng cable from digirig directly. I’m having trouble using the PTT feature to transmit with my UV-5R. Using Winlink Express and VHF Vara FM Link mode with PTT configured to the RTS PTT pin and the cable I bought directly from Digirig Winlink express will lock the digirig transmitter open with no audible activity when attempting to send an email. Unplugging the usb from the Macbook emulating windows 10 it is connected to and the transmitter continues to be held open with no audible tones. Sometimes plugging the Digirig back in to the usb and the laptop won’t detect it until I reboot too. When I plug a headphone into the audio connection of the digirig instead of the Baofeng I hear what are obvious digital packets so whatever is wrong I suspect is likely PTT related and I wouldn’t rule out chinese QC either. What should I check that I might have overlooked? Thanks so much for the help.

This is likely RFI related. The unbalanced antenna really close to the rest of the kit wrecks havoc on the USB communication.

Please check out “Sticky transmission, Errors on Transmission” section of the troubleshooting guide for the ways to confirm the diagnosis and ways to address the situation.

Additionally to homebrew remedies, the ferrite choked shorter USB cable and/or USB isolator might help.

Thanks! I simply moved the radio about 4 feet from the laptop using the length of the cable I already had plugged in and it worked perfect!

2 Likes